Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: zsh crash in recent -current

I saw the one with the trashed history as well.

I don't think it is zsh's problem, though. As I mentioned above, I've
used v5.7 since it came out without any problems until perhaps 3-4
days ago.

I tried to build zsh with debug (adding  --enable-zsh-debug
--enable-zsh-mem --enable-zsh-mem-debug --enable-zsh-mem-warning
--enable-zsh-secure-free --enable-zsh-heap-debug
--enable-zsh-hash-debug to the makefile), but I still get a stripped
executable, no doubt I miss some pkgsrc environment variable. If I try
to build it within the work folder with gmake, it refuses to build the module, which is one of the failing ones.

On Tue, 12 Mar 2019 at 21:58, Thomas Klausner <> wrote:
> On Tue, Mar 12, 2019 at 03:33:26PM +0000, Chavdar Ivanov wrote:
> > On amd64 -curent from yesterday (and a couple of days earlier) I
> > started to get zsh crashes when tab-completing  (files, directories,
> > packages), similar to
> I see lots of crashes with zsh too.
> Some happen in completion, sometimes when I press enter on a command
> line, sometimes the history gets trashed (lots of weird characters
> turn up when I press 'up') and the shell dies soon after.
> I think there are at least two different bugs in zsh here.
>  Thomas


Home | Main Index | Thread Index | Old Index