Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ThinkPad - suspend-to-RAM intel-x86 issues and tests

On Tue, 2018-11-20 at 16:25 +0100, Riccardo Mottola wrote:
> Hi David,
> David H. Gutteridge wrote:
> > FWIW, I'm able to get suspend and resume to work reliably on a
> > Lenovo
> > T420 with NetBSD-8.0_STABLE. (With 8.99.x, it doesn't work as
> > reliably
> > because the SATA driver seems to have issues after resumption which
> > don't occur with 8.0.) I didn't have to do anything of note to get
> > it
> > to work, it just does, assuming there's nothing extra attached.
> > (Read
> > on below.)
> The T420 is a lot newer and is amd64 instead of x86.

True. What I can also say is that I tested the i386 port with it too
(see kern/53658), and it worked too. I've also tested i386 with an LG
X110 that I used to run NetBSD 5.x and then 7.x on. I could never get
it to suspend. With 8.0, it doesn't resume successfully, because of an
issue with the i915 DRM driver, but with the newer DRM code base that
was pulled into HEAD, I've found 8.99.25 did successfully resume, so
there may be hope.

I have access to a Toshiba Satellite Pro that's a roughly similar
vintage to your T43; I'll see how it behaves when I have a chance.

> > On the other hand, I cannot get it to work on a Lenovo x131e (the
> > AMD
> > CPU version, with Radeon graphics). With that machine, it resumes,
> > but
> > the display stays dark. (This behaviour is consistent with most
> > Linux
> > kernels I've tried as well, so there's something tricky about it.)
> Yes, I have this issue on the T43 with ATI graphics, however it often 
> does work and come back (but takes several secons) it is unreliable,
> but 
> the only ThinkPad I have NetBSD on which sometimes suspends/resumes 
> correctly.
> Did you try disabling video in configure and then trying to 
> suspend/resume after a clean boot?

I haven't tried that yet, no. I'll add it to the list.

> Christos suggested to me disabling video and audio (things in my 
> experience cause issue too).
> I tried also fine-grained disabling based on dmesg devices.
> However, I went down to bare-bones, leaving just internal hard disk
> and 
> keyboard - disabling everything which I could (but perhaps I missed 
> something) and yet it fails!
> > One other thing to consider is whether you have anything extra
> > plugged
> > into the USB stack when you're trying to suspend. I've found having
> > pretty much anything plugged in (including a mouse) causes my T420
> > to
> > fail to completely suspend.
> Indeed, I did all the test with a just clean-booted machine with no
> USB 
> mouse, keybord, dongles or else.
> It did not help.

Hopefully, we'll figure this out.


Home | Main Index | Thread Index | Old Index