Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: New panic in wdc_ata_bio_intr

Examining the relevant commit in this period, it is only the NCQ update which has anything to doç
Merge support for SATA NCQ (Native Command Queueing) from jdolecek-ncq branch 

It is way too complicated for me to try to back it out piecemeal to find something. But as far as I understand it from the messages, this is still w.i.p., so perhaps I should just wait...

Chavdar Ivanov 

On Mon, 9 Oct 2017 at 14:49 Chavdar Ivanov <> wrote:
A bit sad responding to myself... Anyway,

works fine.


in case someone else is hit by this - on a very standard ThinkPad T61p. 

Chavdar Ivanov

On Mon, 9 Oct 2017 at 11:43 Chavdar Ivanov <> wrote:
The same happens with the kernel built some hour ago. The last kernel I am running on the T61p is from 05/10/2017. 

I just tested with exactly the same result. There have been quite a few recent changes in wd/ata areas and apparently the fallout hasn't been cleared yet. 

As I mentioned earlier, dump is not created.

Chavdar Ivanov

On Sun, 8 Oct 2017 at 15:17 Chavdar Ivanov <> wrote:
I tried the same kernel on a VirtualBox guest - it doesn't crash, but one gets endless 

piixide0:1:0: lost interrupt
        type: atapi tc_bcount: 0 tc_skip: 0

stream of messages. Also /etc/rc.d/swap2 start hangs while trying to add /dev/cd0a as a dump device... as shown by ktruss. 



On Sun, 8 Oct 2017 at 11:55 Chavdar Ivanov <> wrote:
System updated about two hours ago. I am getting:

wd0 at atabus0 drive 0
wd0: <Hitachi HTS725032A9A364>
wd0: drive supports 16-sector PIO transfers, LBA48 addressing
wd0: 298 GB, 620181 cyl, 16 head, 63 sec, 512 bytes/sect x 625142448 sectors
piixide0:0:0: bad state 0 in wdc_ata_bio_intr
panic: wdc_ata_bio_intr: bad state
fatal breakpoint trap in supervisor mode
trap type 1 code 0 rip 0xffffffff8021c0c5 cs 0x8 rflags 0x246 cr2 0 ilevel 0x8 rsp 0xffffe40040003c38
curlwp 0xffffe4013bb27840 pid 0.2 lowest kstack 0xffffe400400002c0
Stopped at pid 0.2 (system) at netbsd:breakpoint+0x5: leave
db{0}> bt
breakpoint() at netbsd:breakpoint+0x5
vpanic() at netbsd:vpanic+0x140
snprintf() at netbsd:snprintf
wdc_ata_bio_poll() at netbsd:wdc_ata_bio_poll
intr_biglock_wrapper() at netbsd:intr_biglock_wrapper+0x1d
Xintr_ioapic_edge10() at netbsd:Xintr_ioapic_edge10+0xee
--- interrupt ---
x86_mwait() at netbsd:x86_mwait+0xd
acpicpu_cstate_idel_enter() at netbsd:acpicpu_cstate_idle_enter+0xdb
acpicpu_cstate_idle() at netbsd:acpicpu_cstate_idle+0xb6
idle_loop() at netbsd:idle_loop+0x18c

(that is on my usual ThinkPad T61p).  

Couldn't get a crash dump. 

Chavdar Ivanov

Home | Main Index | Thread Index | Old Index