Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

X Server struggle

I’m running -current on a new laptop (it won’t run anything earlier), and now trying to get X up and working.  Tried “Xorg” and then looked at the Xorg.0.log file and find “No screens”.  So I cobbled together an xorg.conf file and then I get a “No devices found” and with that I get a “No monitor” but adding that I’m back to “No matching screens” and “Screens deleted”.  The name pointers all appear to be correct stringing the Screens, Devices and Monitor sections together.  Typically I’ve always had to build an xorg.conf file on my other systems to get them to work for me, so I’m slightly familiar with this procedure.

I tried running MintLinux 18.1 on this laptop and it comes up with X running.  The server log there indicates it’s using the same version of the server and build date as -current, but it has some messages indicating “automatically auto detect and enable of devices”.  There is no xorg.conf file on the MintLinux system but it does process some override files.  However, none of the override files contain anything related to the Monitor, Screens or ServerLayout.

So I added a ServerLayout to my xorg.conf on -current and inserted the Options for AutoAddDevcies and AutoEnableDevices.  I get a message indicating the server isn’t built with the backend configure so these options are being ignored.

As far as I can tell the only difference seems to be the backend configure option was included in the MintLinux X server, but wasn’t in the -current X server.  (Other than there are also references to a mode setting module in MintLinux that doesn’t show up in the -current logs.)

Before I try going down the modular X rabbit hole, is there any reason the backend configure option isn’t enabled in the X server for NetBSD, and if not, how do I enable it?  Or am I already down the rabbit hole and totally lost yet once again?


Home | Main Index | Thread Index | Old Index