Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: USB Issues in 7.1_STABLE

On 04/22/17 20:05, Gary Duzan wrote:
In Message <>,
    Nick Hudson <>wrote:

=>On 04/22/17 13:57, Gary Duzan wrote:
=>>     Booting from the installer image, I noticed a couple of USB related
=>> issues. First, the boot menu wouldn't recognize my USB keyboard;
=>> I had to hit ENTER on my PS/2 keyboard to get the boot to continue.
=>> Then the boot process stopped after probing usb1 (see dmesg below),
=>> only continuing after I pressed a key on the PS/2 keyboard. It
=>> seemed like my USB devices worked after that, but I didn't do any
=>> additional testing.
=>>     Is there anything I can do to help diagnose the problem?
=>xhci  debug output please

I mean compile a kernel with XHCI_DEBUG and set xhcidebug=20 and extract the output. See the URL for more details

    All I see different is the kbd probe and hub ordering. (See diff
below.) I should correct myself about the boot menu: the USB keyboard
doesn't work on that with my March 27 7.1_STABLE bootloader, either,
so the only real concern is the boot hang.

=>> xhci0 at pci2 dev 0 function 0: vendor 0x1033 product 0x0194 (rev. 0x03)
=>> xhci0: interrupting at ioapic0 pin 17
=>> xhci0: xHCI version 0.96
=>> usb0 at xhci0: USB revision 3.0
=>> usb1 at xhci0: USB revision 2.0
=>> [boot pauses here]
=>Not sure NEC controllers are working yet, although does HEAD do any better?

    It has been a while since I tried, but the result was similar,
which was why I held off switching to -current. Getting USB3 working
would be awesome, but initially I'd settle for the driver not being
troublesome. Again, if there is anything I can do to help, let me

There's at least of xhci change on HEAD over netbsd-7 and all sorts of other fixes, so it'd be good to test HEAD.



Home | Main Index | Thread Index | Old Index