Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: No console

On Thu, Apr 06, 2017 at 09:02:25PM +0100, Robert Swindells wrote:
> Jim Bernard wrote:
> >Yes, I've been having the same problem, also with -current amd64 kernels.
> >It occurs on both a Dell Optiplex 960 with an Intel E8400 cpu and an Nvidia
> >GeForce 9300 GE card that nouveau doesn't handle (so I use no drm in the
> >kernel) and on a Lenovo T61 laptop with an Intel T9300 cpu and i965GM
> >graphics that drmkms doesn't handle (so I use legacy drm in the kernel).
> >On both machines, there is text from the boot code, but none from the kernel
> >or any userland programs that run during multiuser startup, including getty.
> >There is a cursor, and it moves occasionally, but no text is printed.  If I
> >type blindly, I can log in (still no text printed) and start X, which does
> >correctly generate its usual display.


> The cause looks to be this:
> <>
> Backing out the change restores the console for me.

It's sufficient to revert just the last (2nd) alignment change in kern.ldscript
to restore console output on the optiplex.  I haven't tried the thinkpad yet.

Home | Main Index | Thread Index | Old Index