Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Is NetBSD ReFUSE layer capable to do MTP?

Rhialto <> writes:

> On Sun 04 Sep 2016 at 19:15:07 +0000, Daniel Ölschlegel wrote:
>> The library libmtp(in Pkgsrc) comes with a test program which should
>> list some devices, so maybe its a problem with the library which i can
>> debug if someone could establish a connection.
> Yes, I don't see my phone attached either with test programs like
> mtp-connect or mtp-detect.
> -Olaf.

Hello..  I was just messing with libmtp.  I attached it to a Sandisk
CLIP zip audio player in MTP mode, an old Android 4.2 tablet and a
Android 6.0.1 Cyanogenmod 13 based phone.  What I noted was that it can
take a VERY long time for the mtp test programs to actually finish
connecting...  think many minutes.  If mtp-detect just appears to hang,
try waiting a while and see if it ever returns.

The audio player worked the best, just a second or two to do most
operations, but it probably is the simplest.  The 4.2 Android tablet
also worked and I moved files from it without any real problems.  I
didn't fiddle much with the Cyanogenmod 13 based phone much as it way
too long for it to actually complete any operations.  It was much
simpler to just sftp files out of the device via 802.11.

Brad Spencer - - KC8VKS  - & - [IPv6 only]

Home | Main Index | Thread Index | Old Index