Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Ext2 issues in current

In article <20160821004610.GA1302@netbox.brkly.local.domain>,
Mike  <> wrote:
>Hi Folks.
>It seems to me that last changes in <ext2fs> completly broke NetBSD's
>write support on it (in expected way, as it used to work for a very
> long time before). I started having troubles about 2 weeks ago. 
>At that time, I was hoping that this is just a temporary issue in
>-current, and probably will be fixed soon...But now I'm not so sure,
> since the problem is still there.
>General info: Host system-amd64 (yesterday's "clean" -current build)
>So, basicaly I have the following picture today:
>1). A few partitions with ext2 filesystem. (Used to provide some
>  interoperability with other OS's, although I'm using only netbsd,
>  ~90% of time...and this partitions are also being used as read-only,
>  most of the time. But sometimes I'd like to have write support as well!.
> I created them(mostly), using only netbsd native tools. (It still did not
>  work very smoothly, but worked quite acceptably for a while).
> -features list : resize_inode filetype sparse_super large_file.
> -fs revision   : 1.  Of course, since I want to be able to put(sometimes)
>                      large files there...
>2). Latest netbsd-current system
>3). In Read-Only mode it works normally
>4). Write support is still present... But works totally weird...
>   (_absolutely_ sure that It is just _new_,  _netbsd_ , trouble
>     - not hardware or anything else). 
>In the attached text file, I wrote typical  shell session, demonstrating
>it's "work" in the rw mode(not the worst case, cause with latest changes
> it looks more like loterea....- you never know what exactly you'll get,
> trying to use  ext2fs rw. Most common result is total freezed system with
> need to hard-reset..-> -> fsck and finally -> some pieces of data,
> more or less, written on disk. when using kernel-level driver, I mean.
> If using rump, tipically it will crash quckly...resulting -dirty filesystem.
> Esplecially, when writing big amounts of data and/or under high disk
>  IO load, etc)
>Just wondering - Is that a known behavior?

I think it broke as part of the GSoC changes were committed. I also think
that Jaromir fixed it yesterday, but I am not sure yet.


Home | Main Index | Thread Index | Old Index