Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Latest amd64 snapshot has problems with disk sizes

Just tried to install current using the latest AMD64  snapshot 201512071640Z 
on a blank SATA drive. Boots up off the memory stick OK and after allocating 
partitions it fails when trying to newfs the first partition rwd0a. An error:
ioctl DIOCGMEDIASIZE failed 19 appears in the log messages several times.

The first partition (rwd0a) is set to be 512M and the newfs croaks with:

/sbin/newsfs -V2 -O2 -b 8182 -f 1024 /dev/rwd0a

Newfs: size 488397168 exceeds 525168 sector filesystem size on '/dev/rwd0a'

Retrying doesn't work as the installer can no longer see the disk unless the 
install is rebooted. I haven't tried setting different partition size for wd0a 
as 512M is normally fine for root. Disk is a 232GB Western Digital. 
I can send-pr a bug report if required.


Phone: 07805784357
Open Source O/S:

Home | Main Index | Thread Index | Old Index