Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Cross-build failure from Linux


I'm trying to cross-build NetBSD/macppc from a Debian testing
installation on a PowerMac G5 (ppc64). In doing so, I hit the error
below during the build of gcc as part of " tools":

----- cut here -----
configure:5635: checking for the correct version of the gmp/mpfr/mpc libraries
configure:5666: cc -o conftest -O
-I/home/jmmv/os/netbsd/macppc/tools/include    conftest.c
-L/home/jmmv/os/netbsd/macppc/tools/lib -lmpc -lmpfr -lgmp >&5
/home/jmmv/os/netbsd/macppc/tools/lib/libgmp.a(divrem_1.o): In
function `__gmpn_divrem_1':
divrem_1.c:(.text+0x1b8): undefined reference to `__multi3'
divrem_1.c:(.text+0x2a0): undefined reference to `__multi3'
divrem_1.c:(.text+0x340): undefined reference to `__multi3'
divrem_1.c:(.text+0x520): undefined reference to `__multi3'
divrem_1.c:(.text+0x608): undefined reference to `__multi3'
more undefined references to `__multi3' follow
collect2: ld returned 1 exit status
configure:5666: $? = 1
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME ""
| #define PACKAGE_TARNAME ""
| #define PACKAGE_VERSION ""
| #define PACKAGE_STRING ""
| #define PACKAGE_URL ""
| #define LT_OBJDIR ".libs/"
| /* end confdefs.h.  */
| #include <mpc.h>
| int
| main ()
| {
|     mpfr_t n;
|     mpfr_t x;
|     mpc_t c;
|     int t;
|     mpfr_init (n);
|     mpfr_init (x);
|     mpfr_atan2 (n, n, x, GMP_RNDN);
|     mpfr_erfc (n, x, GMP_RNDN);
|     mpfr_subnormalize (x, t, GMP_RNDN);
|     mpfr_clear(n);
|     mpfr_clear(x);
|     mpc_init2 (c, 53);
|     mpc_set_ui_ui (c, 1, 1, MPC_RNDNN);
|     mpc_cosh (c, c, MPC_RNDNN);
|     mpc_pow (c, c, c, MPC_RNDNN);
|     mpc_acosh (c, c, MPC_RNDNN);
|     mpc_clear (c);
|   ;
|   return 0;
| }
configure:5670: result: no
configure:5691: error: Building GCC requires GMP 4.2+, MPFR 2.3.1+ and
MPC 0.8.0+.
Try the --with-gmp, --with-mpfr and/or --with-mpc options to specify
their locations.  Source code for these libraries can be found at
their respective hosting sites as well as at  See also for additional info.  If
you obtained GMP, MPFR and/or MPC from a vendor distribution package,
make sure that you have installed both the libraries and the header
files.  They may be located in separate packages.
----- cut here -----

Any ideas?

In fact, I haven't been able to crossbuild NetBSD from non-NetBSD
hosts for a while, and I think I tried various variants of Linux and
FreeBSD... although I can't remember if I tried elsewhere than on this


Julio Merino / @jmmv

Home | Main Index | Thread Index | Old Index