Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

lvm lvremove failure

Pardon the repost, for some reason the mail got into the wrong thread.

When I tried to remove an LVM logical volume I got an error as shown

# lvm lvremove vg00/lvtest02
Do you really want to remove active logical volume lvtest02? [y/n]: y
  Unable to deactivate logical volume "lvtest02"

Deactivating vg00/lvtest02 produces:

# lvm lvchange -an vg00/lvtest02
  Command failed with status code 5.

I think it's essentially a problem with deactivating a logical volume,
which evidently needs to be done before removing the lv. Does anyone
else has this problem?

The physical volume is in a slice of a raidframe device. Kernel is
5.99.45, amd64, dated 2011-02-14 05:00Z. The LV was not mounted or had
any fs on it. I tried a newer userland lvm from 2011-04-06 03:20:02Z and
got what seems to be essentially the same problem.

I localize the problem as far as to be somewhere in deactivate_lv() which
is a define in dist/lib/locking/locking.c. Then, I'm lost.

Additionally after the failed attempt to deactivate any LV, using dd on
the raw LV would no longer be possible because there is no more space
available, as shown below:

# lvm lvcreate -L 2G -n lvtest03 vg00
  Logical volume "lvtest03" created
# dd if=/dev/zero of=/dev/vg00/rlvtest03 bs=1m count=100
100+0 records in
100+0 records out
104857600 bytes transferred in 1.426 secs (73532678 bytes/sec)
# lvm lvchange -an vg00/lvtest03
  Command failed with status code 5.
# dd if=/dev/zero of=/dev/vg00/rlvtest03 bs=1m count=100
dd: /dev/vg00/rlvtest03: No space left on device
1+0 records in
0+0 records out
0 bytes transferred in 0.003 secs (0 bytes/sec)



Home | Main Index | Thread Index | Old Index