Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Installation of NetBSD 5.99.44 and resulting problems

} mmap /dev/mem: Permission denied
} Failed to initialise LRMI (Linux Real-Mode Interface).

} I can't see why I got this message on 5.99.44 but not 5.1_STABLE.

} I was still able to run "shutdown -r now", even though I couldn't see 
anything on the screen until I was out of NetBSD and into reboot.

} Tom

> On -current you need to set sysctl vm.user_va0_disable=0

> Jared

That helped, but only partly.  Actually it didn't quite work as you wrote 
verbatim, but the error message led to the correction, I needed "-w":

sysctl -w vm.user_va0_disable=0

Then vbetool ran without "Permission denied", but I still couldn't get the 
screen back from darkness after leaving X in 5.99.44 as I did in 5.1_STABLE.  
But I could still get back to X with "startx" or type "shutdown -r now" 

In 5.1_STABLE, being able to bring the screen back from darkness works only 
when vesafb is enabled in the kernel config.  I run 

vbetool vbemode get

before going into X to get the mode, then after leaving X,

vbemode vbemode set nnnnn

replacing nnnnn by the mode I got from 

vbetool vbemode get

I even could combine this with the startx as

startx && vbetool vbemode set nnnnn

(nnnnn as before).

I have yet to try, in 5.99.44, using /etc/X11/xorgvesa.conf in place of the 
regular /etc/X11/xorg.conf

Being in Linux as I type this, I can't read my 5.99.44 installation.

I might try to update my 5.99.44 installation from (http:// or 

but only if I get some indication of the bug being fixed, otherwise too many 
hours of futility.


Home | Main Index | Thread Index | Old Index