Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: loading new envstat properties reboots system


I only have one machine remaining with an amdtemp sensor. I tried to reproduce this problem, but was unsuccessful. My kernel is a bit newer than yours - 5.99.39 from 2010-10-28 16:51:58 UTC. (The Aug. 11 kernel no longer exists on as far as I can see.)

There was only one change to envsys code between your kernel and mine:

   Module Name:    src
   Committed By:   pgoyette
   Date:           Wed Sep 22 00:13:55 UTC 2010

   Modified Files:
        src/sys/dev/sysmon: sysmon_envsys_events.c

   Log Message:
   1. Don't try to call the driver's get_limits routine if it doesn't
      have one.  Fixes a panic reported by njoly@ in private Email

   2. Acquire the device before checking whether or not the get_limits
      routine exists.

   XXX There's still a bug in here somewhere that prevents setting of
   XXX limit values after using 'envstat -S'

   To generate a diff of this commit:
   cvs rdiff -u -r1.92 -r1.93 src/sys/dev/sysmon/sysmon_envsys_events.c

It is entirely possible that this is the source of your problem.

There have recently been some additional changes in this area to fix bugs the prevented limits from actually being removed (even though envstat seemed to indicate that they were removed). If possible, you should update.

Otherwise, you should avoid using "envstat -S", which also means avoid using "/etc/rc.d/envsys stop" or "/etc/rc.d/envsys restart".

On Mon, 13 Dec 2010, Jeremy C. Reed wrote:

The envstat output is:
                 Current  CritMax  WarnMax  WarnMin  CritMin Unit
 CPU0 Sensor0:    70.500   92.000                     85.000 degC
 CPU0 Sensor1:    73.250   92.000                     85.000 degC
 CPU1 Sensor0:    68.500   92.000                     85.000 degC
 CPU1 Sensor1:    67.250   92.000                     85.000 degC

The dmesg is at

NetBSD 5.99.38 NetBSD 5.99.38 (GENERIC) #0: Tue Aug 10 19:00:23 UTC 2010
amd64 x86_64

I set ddb.onpanic=1.

I ran envstat -S and got:

uvm_fault(0xffff80003eb3eba0, 0x0, 4) -> e
fatal page fault in supervisor mode
trap type 6 code 10 rip 0 cs 8 flags 10246 cr2 0 cp 0 rsp ffff8000003e1598c8
kernel: page fault trap, code=0
Stopped in pid 6850.1 (envstat) at     0:  invalid address

bt resulted in
Faulting DDB, continuing

so did a sync and that dumped to dev 0,1 offset 267193
... 3 2 1 succeeded

I have these in /var/crash/

-rw-------  1 root  wheel  449947102 Dec 13 12:17 netbsd.1.core.gz
-rw-------  1 root  wheel     479688 Dec 13 12:17 netbsd.1.gz

(gdb) target kvm netbsd.1.core
#0  0x00000000 in sigcode ()

No problem running this envstat -S at initial startup though (via
/etc/rc.d script).

(By the way, I don't know why I didn't get this crash dump earlier. I
thought it was automatic with kern.dump_on_panic=1.)


| Paul Goyette     | PGP Key fingerprint:     | E-mail addresses:       |
| Customer Service | FA29 0E3B 35AF E8AE 6651 | paul at    |
| Network Engineer | 0786 F758 55DE 53BA 7731 | pgoyette at |
| Kernel Developer |                          | pgoyette at  |

Home | Main Index | Thread Index | Old Index