Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: any support for Atheros AR9285 wireless and AR8132 ethernet?

(This response is about the AR9285 wireless. It works, but not perfect. 
See below.)

On Thu, 27 May 2010, Arnaud Lacombe wrote:

> Patches are available there:
> As said previously, it builds only, no further testing done. There is
> still one FIXME in ath_rate_tx_complete() on which I will have to pay
> a closer attention to. Moreover, the config(4) macro is not right for
> eeprom4k.
> I should able to test AR5424 and AR5211. I do have an AR92xx-based
> card, but the MIPS board associated does not run NetBSD yet, so this
> will be up to you :)

It built fine.

ath0 at pci2 dev 0 function 0
ath0: interrupting at ioapic0 pin 17
ath0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
ath0: mac 192.2 phy 14.0 radio 12.0

When I did:

        ifconfig ath0 nwid MYNWID nwkey MYNWKEY up

the kernel said:

        ath0: setting keyix 0 w/o power

ifconfig continued to show "status: no network" ... but then ...

Maybe about 20 seconds later it said:

        ath0: device timeout (txq 1, txintrperiod 5)

And ifconfig shows:

        ssid MYNWID nwkey MYNWKEY
        powersave off
        bssid 00:18:01:e0:8a:57 chan 6
        address: c4:17:fe:31:f7:17
        media: IEEE802.11 autoselect (DS11 mode 11b)
        status: active
        inet6 fe80::c617:feff:fe31:f717%ath0 prefixlen 64 scopeid 0x2

(correct ssid and nwkey as seen on other systems here)

"wiconfig ath0 -D"  works!

"dhclient ath0" works, but said:

        ath0: device timeout (txq 1, txintrperiod 5)

(On other tests I got txintrperiod 4 and 3 and 2 also.)

I can ping its own IP locally.

I can not ping my gateway. And from a remote system I can't ping the new 

So the device works enough for dhclient to give it an IP and resolv.conf 

The "netstat -rn" had many errors (46 lines):
netstat: kvm_read: Bad address
and then:

Destination        Gateway            Flags    Refs      Use    Mtu  Interface
af 0: Q00        UGS         0        0      -  ath0
192/8              UGRS        0        0  33192  lo0          UH          2        3  33192  lo0
127.0.0/24         link#2             UC          1        0      -  ath0
link#2             00:0f:b3:55:e4:27  UHLc        1       79      -  ath0
00:0f:b3:55:e4:27          UGHS        0        3  33192  lo0

I do not recognize "af 0: Q00" interface.

I do not understand why ath0 has 127.0.0/24. For some reason it thinks 
my gateway is available via the loopback. Hopefully this provides a 
clue. See below on my workaround.

00:0f:b3:55:e4:27 is my gateway. That is

I also don't recall netstat -rn ever showing a MAC address as a 

Note I was testing "alc" at the same time. I rebooted and "disable alc*" 
to make sure that is not used (even though I don't see any way they 
could conflict.)

I learned that "dhclient ath0" does not work unless I do "wiconfig ath0 
-D" first.

On a different reboot my netstat -rn showed:

Destination        Gateway            Flags    Refs      Use    Mtu  Interface
af 0: Q00        UGS         0        0      -  ath0
192/8              UGRS        0        0  33192  lo0          UH          2        3  33192  lo0
127.0.0/24         link#1             UC          1        0      -  ath0
link#1             link#1             

I lost rest when the some unrelated acpibat kernel messages appeared to 

But when I tried again it changed back to what I showed above (except 
link#1 instead of link#2).

So I did: "route change default" and it worked. I could ping 
gateway. I could ping this new device from remote system. I could start 
sshd and I can't ssh to it!

Thanks! Now that I have network access to it, it is easier than copying 
files to a USB flash disk :)

Home | Main Index | Thread Index | Old Index