Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: device timeouts on hard disks no matter what..

On Dec 7, 2009, at 10:59 PM, Manuel Bouyer wrote:
> Linux at last also print them (but with a different format of course).
> I'm not seeing this on production machines. I've seen this on occasion,
> and it turned out to be hardware-related (the disk is dying and takes too
> long retrying to get the data, or the power supply is too short).
> If you already tried new disks, I would try a stronger power supply next
> (this fixed the issue for me on several occasion).

I ran NetBSD from 2.0 to 5.0 on a VIA Mini-ITX motherboard with
RAIDframe in RAID-1 without those problems. When the VIA motherboard
broke down I replaced it with an Intel Mini-ITX (with a dual-core
Atom 330). Then the problems started. I had exactly the same PSU,
but I also bought larger disks. Now the machine changed to ATX
form factor with a 2.4 GHz Core 2 Duo. First the problems seemed
to have gone away, but now they came back. The PSU is a 450W
Antec. I could try to put the disks to a Core i7 machine with
a 700W PSU. It came to my mind that maybe it has something to
do with multi-core CPU. But maybe that also contributes to the
PSU problem.

> What model of controller is it ? I see it's called ahcisata1
> so I guess it's a add-on ?

It is what is integrated on Asus P5B motherboard. Here are some
parts of dmesg. Does it look ok?

server# dmesg|grep ahci
ahcisata0 at jmide0
ahcisata0: AHCI revision 1.0, 2 ports, 32 command slots, features 0xc722e000
atabus0 at ahcisata0 channel 0
atabus1 at ahcisata0 channel 1
ahcisata1 at pci0 dev 31 function 2: vendor 0x8086 product 0x2824
ahcisata1: interrupting at ioapic0 pin 19
ahcisata1: AHCI revision 1.1, 4 ports, 32 command slots, features 0xef20e0e0
atabus4 at ahcisata1 channel 0
atabus5 at ahcisata1 channel 1
atabus6 at ahcisata1 channel 4
atabus7 at ahcisata1 channel 5
ahcisata1 port 0: device present, speed: 3.0Gb/s
ahcisata1 port 1: device present, speed: 3.0Gb/s
wd0(ahcisata1:0:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 6 (Ultra/133) 
(using DMA)
wd1(ahcisata1:1:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 6 (Ultra/133) 
(using DMA)


Home | Main Index | Thread Index | Old Index