Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Exponential failure

Hello all.

I wanted to build a -current kernel in an 5.0.1 machine, in order to
test a patch.

I tried kernel, but in the next boot NetBSD was unable to
mount root. It turned out that I had to build modules as well. This
could be documented in `tracking netbsd current' section in our guide,
beyond BUILDING.

After that, I had to copy the modules in the appropriate
/stand/modules directory and NetBSD did load ffs during boot.
But it was unable to exec init, due to a missing exec* module?
I've been told to copy boot file to /, but for that I needed to build

Finally someone advised me to build MONOLITHIC kernel, which kind of worked.

Had it not been for #netbsd @ freenode, I wouldn't possibly have been
able to work around my problems.
I politely and respectfully ask from NetBSD developers to think more
in terms of usability & least surprise principle in the future.

I write this email having in mind those who appreciate benign feedback.
I know there will be some that will get defensive.

Best regards,

Home | Main Index | Thread Index | Old Index