Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: netbsd-5 sets with latest xsrc available for testing

On Sun, Sep 13, 2009 at 05:42:44PM +1000, matthew green wrote:
>    I tried your updated x*.tgz sets on my netbsd-5/amd64 system (without
>    deploying the base and other sets), but the X server wouldn't start.
>    With my existing config it failed to load several modules (cfb, cfb32,
>    mfb, xtrap, ...), and with a newly generated config (X -configure) it
> these are all to be expected -- they no longer exist.
>    said: 
>    (EE) RADEON(0): Unable to map MMIO aperture. Invalid argument (22)
>    (EE) RADEON(0): Memory map the MMIO region failed
>    (EE) Screen(s) found, but none have a usable configuration.
> i know what this is from, there are some pullups i need to get started.
> (you want sys/dev/pci/pci_usrreq.c 1.20, 1.21, and 1.22, if you or anyone
> want to try it out.)

Yes, that fixed it.  I applied everything from rev. 1.60-1.22 and it works
now with the radeon driver (not with radeonhd though).

If you want to get this pulled up into the netbsd-5 release branch we'd
have to come up with a solution for the xorg.conf configuration though,
to not break people's working setups.

(another minor change I had to make is that "colemak" is not a proper
keyboard layout anymore with xkeyboard-config but an xkbvariant of the
"us" layout.)


Geert Hendrickx  -=-  -=-  PGP: 0xC4BB9E9F
This e-mail was composed using 100% recycled spam messages!

Home | Main Index | Thread Index | Old Index