Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index] error ### bootxx_ffsv2 size 7964 is larger than 7680

Dear netbsd devels,

i got this error by building a release by:

#      link  bootxx_ffsv2/bootxx_ffsv2
/var/netbsd/src/../tools/bin/i486--netbsdelf-gcc -o bootxx_ffsv2.sym  -nostdlib 
-Wl,-N -Wl,-e,start  -Wl,-Ttext,0x600  -Wl,-Map, -Wl,-cref 
pbr.o label.o bootxx.o 
/var/netbsd/src/../tools/bin/i486--netbsdelf-objcopy -O binary bootxx_ffsv2.sym 
### bootxx_ffsv2 size 7964 is larger than 7680
*** [bootxx_ffsv2] Error code 1

when build a release by:

        sh -m i386 -O ../obj/ -T ../tools -X ../xsrc -R ../release -j 
2 -U -u -r release releasekernel=XEN3_DOMU_NIELS iso-image

This happens on a freshly checked out current as at some of my tries several 
monthes before.

I tried this build on different netbsd (4.x) with different checkouts and under 
cross building on Gentoo linux machines - with same result.

If i comment out bootxx_ffsv2 (as i dont need this boot option) or change the 
var 7680 to that higher value - then i get a installable system for me, but i 
assume this problem would affect other users too when they try to build their 
own netbsd by following netbsd docs.

best regards,




  Niels Dettenbach
  Syndicat IT&Internet
  T.-Muentzer.-Str. 2, 37308 Heilbad Heiligenstadt - DE
  PGP public key ID 651CA20D
  Fingerprint: 55E0 4DCD B04C 4A49 1586  88AE 54DC 4465 651C A20D

Home | Main Index | Thread Index | Old Index