Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Disabling ACPI also implicitly disables SMP support for Intel Atom chips?

On Wed, 04 Mar 2009 22:25:35 -0500, David H. Gutteridge wrote:
The main problem I've found so far with ACPI being enabled (I've only
been using this machine a few days) is that the Ethernet card doesn't
work.  With ACPI, the card doesn't seem to transmit any packets, and
every few seconds I see the following output to the console:

re0: watchdog timeout
re0: reset never completed!

If I disable ACPI, the re(4) card works fine.

Following up on my own comments, I found another NetBSD user's comments
instructive[1].  Martijn van Buul had written: "I'm having problems
with either my network adapter, or my keyboard. I get to choose; if I
disable ACPI, my ethernet adapter will work just fine but my keyboard
won't, if I enable ACPI my keyboard will work, but my ethernet won't.
The peculiar thing is that *both* worked at the same time during
installation."  (In his case he's using an Acer Aspire One.)  Like me,
his dmesg has the "watchdog timeout" errors at the end, and like me,
he's using an re(4) card.

I thought back to my install, and remembered I'd noted the same thing:
the GENERIC kernel I'd booted during install had ACPI enabled, I
believe.  The re(4) card had worked fine then for me too, as I'd
transferred files via ftp with it.  I guessed that somehow configuring
the card during the boot process rather than afterward was triggering
this "watchdog timeout" problem.

So I removed my /etc/ifconfig.re0 file, rebooted with ACPI on, manually
brought up the interface, manually added the default route, and voila,
re(4) works fine.  So that seems to be the workaround for people who
absolutely want both HT and re(4) on these little devils (pun intended
when they're running a BSD).




Home | Main Index | Thread Index | Old Index