Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: lenovo T61: wake-up doesn't enable video

On Wed, 4 Mar 2009 09:13:51 +0100
Thomas Klausner <> wrote:

> Hi!
> I just tried installing the amd64-5.0 snapshot 20090227 iso from
> releng on an lenovo T61.
> Hardware seems to be supported fine so far, except for some warnings
> about wm0 and iwn0.
> I tried suspending with "sysctl -w machdep.sleep_state=3" and it shut
> down. Pressing fn+F4 woke it up again (judging from hard disk activity
> and the status lights below the screen). However, video wasn't enabled
> again, the screen stayed black.
> I tried typing "vbetool post" which gave me some short hard disk
> activity, but the screen stayed black.
> Pressing the power button for 1-2 second gave me an orderly shutdown
> (no fsck on startup), so I guess the wake-up worked fine except for
> the video.
> Suggestions?

Try this.  Before suspending, use 'wsconscfg -g' to learn your screen,
and 'wsconscfg -s 1' to switch to screen 1.  On resume, switch back to
the old screen.  (I have to do that on a T42.)

                --Steve Bellovin,

Home | Main Index | Thread Index | Old Index