Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

modload pf.o and console shows history and unusable (and system lock up for another issue)

I am on

NetBSD 4.99.55 NetBSD 4.99.55 (GENERIC) #0: Fri Mar 7 
09:06:46 CST 2008 

I did:

sudo modload /usr/lkm/pf.o

and my prompt didn't come back.

It showed my console history (which happened to be my green kernel 

I couldn't see what I was typing.

I could press enter and it would scroll and show a new line from my 
previous console history.

So I pressed enter maybe a hundred times and saw:

kernel output (in green)
boot messages and rc.d output again
my login
where I ran modload
kernel output (in green)
and keep looping like that

I had ttyE1 enabled and switching consoles also showed junk on there to 
and unusable.

I tried blindly typing startx and "sudo modunload pf.o" but no change.

Typing "reboot" worked fine.

I can repeat this.

I don't know if it is related to this:
but that was an 4.0_RC2 on same hardware where I also ran modload of pf.o. 
But in that case it didn't lock up immediatetly.

So that 4.0_RC2 issue was over a week ago. I had been using an i386 4.0 
instead to do that modload pf.o for my nat for over seven days fine. This 
morning I moved over to my amd64 -HEAD system (where I did the modload 
pf.o, enabled forwarding and loaded one nat rule) . And it locked up (and 
not pingable) in about 30 minutes. I was in X so I couldn't see what was 
up. That is why I rebooted and tried to do in console but couldn't per 
error at top of this email.

(So now I am trying builting ipnat instead to see if that will work for 

Any thoughts about that console scrolling?

Any thoughts about that lock up?

Here's the kernel:

  Jeremy C. Reed

Home | Main Index | Thread Index | Old Index