Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: ntpd panic but only in a domu

Kimi wrote:
On 28/02/2008, Sarton O'Brien <> wrote:
Sarton O'Brien wrote:
 > I'm still seeing this but only in a domu and only on a domu with significant
 > memory usage (ie. a domu runng slapd/postgress and a domu running
 > apache/zope) and using the 'disable kernel' option  doesn't help, if there is
 > anything else I can provide, let me know. I can trigger this at will:
 > panic: uvm_map_pageable: stale map
 > Stopped in pid 273.1 (ntpd) at  netbsd:breakpoint+0x4:  popl    %ebp
 > db> bt
 > breakpoint(c0432597,cc525b18,c0448080,c028cb4e,ca292320) at
 > netbsd:breakpoint+0x
 > 4
 > panic(c041dd73,bb96f000,bb989000,7,1) at netbsd:panic+0x1bf
 > uvm_map_pageable(ca292310,bb96f000,bb989000,0,1) at
 > netbsd:uvm_map_pageable+0x44
 > 7
 > uvm_mmap(ca292310,cc525cc8,1a000,5,7) at netbsd:uvm_mmap+0x50d
 > sys_mmap(cc4b7620,cc525d00,cc525d28,c0399d15,c038f086) at
 > netbsd:sys_mmap+0x342
 > syscall(cc525d48,1f,1f,bfbf001f,bba6001f) at netbsd:syscall+0xb8

Am I the only one seeing this? I've been holding off on domu updates for
 about 3 months due to this issue, as it seems timed is definately not a
 suitable replacement for ntpd, not at least with dom0 rejecting
 broadcasts. I'd feel less lonely with at least a 'me too' :)

I can not say me too, as I run ntpdate & timed both for DOM0 and
DOMUs. not sure about HVM yet.

ntpdate and timed both work ok. The problem I had with timed was only when it was run within dom0, there was some broadcast issue. Running it from a domu worked fine but the time keeping on a domu is not as accurate IIUC.

I run a ntpd on the firewall along with timed to service everything on
my networks.

are you running powerd? I noticed it doesn't work under an AMD64 DOMU,
powerd complaining about not finding /dev/power

I'll see if I can re-create the same thing.

I'm on i386 and I do run powerd. No issues there. That stuff is pretty solid.

The problem is occurring when /etc/rc.d/ntpd is invoked, either manually or at boot. It doesn't happen in dom0, only a domu ... and only one with a significant amount of memory usage.

Every other domu is fine and they are all theoretically identical with regards to kernel and userland. I'm not quite sure how to recreate the problem from scratch, all I know is two out of four that I have at the moment, have this problem.


Home | Main Index | Thread Index | Old Index