Current-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Early userland crash with current kernel and 4.0 userland

Hi there,

I have received at work a brand new Dell Inspiron 530 with a Core 2 duo proc. I have installed the 4.0 release on it, and proceeded to upgrade it to current (all the more since the default Generic kernel boots in uniprocessor mode).

So I got a current kernel, and tried to boot it. It boots ok, but the system crashes immediately after finishing the init phase, when init forks sh:

uvm_fault (0xcb21cdc8, 0, 1) -> 0xe
kernel supervisor trap page fault, code = 0
Stopped in pid 2.1 (sh) @ netbsd:pool_cache_get_paddr+0x2a

Unfortunately, I can't get any futher debug info, since with the included USB keyboard, I can't type a thing, the machine is mute. The only thing I can do is to reboot.

I tried to cancel the -march switch in CFLAGS, to decomment COMPAT_20, COMPAT_30, but, of course, it has no effect. I'm still stuck — maybe compiling a multiprocessor GENERIC kernel would do the trick, but it still does not explain what's going on.

Any idea?


Home | Main Index | Thread Index | Old Index