Subject: Re: ath0 on cardbus
To: Ed Gould <>
From: Peter Szilagyi <>
List: current-users
Date: 01/03/2007 12:54:56
Ed Gould <> writes:

> Long ago, I used an Atheros-based cardbus WiFi card (ath0), but for 
> various reasons I switched back to a Lucent-based wi0.  Yesterday, I 
> tried the ath0 again.  It was not seen by the kernel (4.99.5 from early 
> December), and when I removed it then re-plugged it, the kernel crashed 
> with a message like "no cardbus0 at cbb0" (from memory).
> I'll try a new kernel first, but before I try to debug this, has anyone 
> else seen anything similar?
> Thanks.
> 	--Ed

I have had a couple of cardbus problems on an IBM ThinkPad 390E,
running 4.0_BETA2 from last week and 4.99.7 from around 2 weeks ago.
I had also been using a wi card before that, and am using one now.

Not quite the same as yours - mine panics when I eject the ath card.
I'll probably submit a PR on this, but haven't searched GNATS yet.

PR kern/35313, a boot hang on the same machine, may be related.
(Probably not, but I do have lots of machines with the same Intel
bridge chip, and only this one with the cardbus trouble hangs.)

I am using the same Netgear ath card successfully in another 4.0_BETA2
laptop, but I don't recall the last time I tried ejecting it.