Subject: Re: NetBSD on Asus F2F Laptop partial success
To: Christian Hattemer <>
From: Chavdar Ivanov <>
List: current-users
Date: 11/11/2006 23:47:56
On 11/11/06, Christian Hattemer <> wrote:
> Hi,
> I've got myself an Asus F2F Laptop and put -current on it. I'll summarize
> below what works and what doesn't work yet. Please CC me on reply.

I had started an earlier thread about my HP nx6310, which is fairly
close to the F2F (broadcom instead of realtek for wired network, no
fingerprint reader, cardbus instead of expresscard).

> Also mixerctl -av
> outputs.mix15=106,106  delta=21
> playback.mode=03  [ 03 07 0405 06 ]

> USB works a bit flaky. It sometimes works on boot and sometimes it doesn't.
> Rebooting usually makes it work. This seems to be random, maybe a race
> condition somewhere.

I have had similar problems a few times with mine, always after a warm
reboot after Windows/XP. It's even weirder with the Broadcom ethernet
- when I shut Windows down, even completely, as long as the power
supply is connected, it never turns off the green light of the network
card, even if I disconnect the cable. If I boot NetBSD at this stage,
I get non-working bce0... So when I have to boot NetBSD after Windows,
I always have to disconnect the power supply... I can live with that,

> When it doesn't work it will report "uhub0: device problem, disabling port
> 1" as seen in the dmesg below. This is the built-in fingerprint sensor, so
> it can't be removed for testing. When this happens all other ports are also
> dead and do not respond to devices being plugged in.

I have the same problem if I boot NetBSD with the wireless button off
- it is because of the BlueTooth connected to a USB hub internally
(the action of the button is defined in the BIOS - I have left the
default that it turns on/off both the WiFi and BT). I also had this a
few times when I booted -current with an external usb2 disk attached.

> Here's a diff to the dmesg when it does work:
> --- dmesg-bug   2006-11-11 12:34:58.000000000 +0100
> +++ dmesg.norm  2006-11-11 12:42:11.000000000 +0100
> @@ -50,8 +50,8 @@
>   acpi0: X/RSDT: OemId <A M I ,OEMRSDT ,07000603>, AslId <MSFT,00000097>
>   acpi0: SCI interrupting at int 9
>   acpi0: fixed-feature power button present
> -timecounter: Timecounter "ACPI-Fast" frequency 3579545 Hz quality 1000
> -ACPI-Fast 24-bit timer
> +timecounter: Timecounter "ACPI-Safe" frequency 3579545 Hz quality 900
> +ACPI-Safe 24-bit timer
>   ACPI Object Type 'Processor' (0x0c) at acpi0 not configured
>   ACPI Object Type 'Processor' (0x0c) at acpi0 not configured
>   ATK0100 at acpi0 not configured
> @@ -95,7 +95,7 @@
>   acpitz0 at acpi0: ACPI Thermal Zone
>   acpitz0: unable to get polling interval; using default of 30.0s
>   acpitz0: passive cooling mode only
> -acpitz0: critical 105.0C passive 52.0C
> +acpitz0: critical 105.0C passive 55.0C
>   pckbd0 at pckbc0 (kbd slot)
>   pckbc0: using irq 1 for kbd slot
>   wskbd0 at pckbd0: console keyboard
> @@ -200,6 +200,8 @@
>   azalia0: codec[1]: No support for modem function groups
>   azalia0: codec[1] has no audio function groups
>   audio0 at azalia0: full duplex, independent
> +ugen0 at uhub0 port 1
> +ugen0: AuthenTec Fingerprint Sensor, rev 1.10/c.10, addr 2
>   wd0 at atabus0 drive 0: <FUJITSU MHV2080BH PL>
>   wd0: drive supports 16-sector PIO transfers, LBA48 addressing
>   wd0: 76319 MB, 155061 cyl, 16 head, 63 sec, 512 bytes/sect x 156301488 sectors
> @@ -211,13 +213,15 @@
>   cd0: 32-bit data port
>   cd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 2 (Ultra/33)
>   cd0(piixide0:1:0): using PIO mode 4, Ultra-DMA mode 2 (Ultra/33) (using DMA)
> +uhidev0 at uhub0 port 2 configuration 1 interface 0
> +uhidev0: Logitech Trackball, rev 1.10/2.20, addr 3, iclass 3/1
> +ums0 at uhidev0: 3 buttons and Z dir.
> +wsmouse1 at ums0 mux 0
>   boot device: wd0
>   root on wd0a dumps on wd0b
>   root file system type: ffs
>   cpu1: CPU 1 running
> -uhub0: device problem, disabling port 1
>   wsdisplay0: screen 1 added (80x25, vt100 emulation)
>   wsdisplay0: screen 2 added (80x25, vt100 emulation)
>   wsdisplay0: screen 3 added (80x25, vt100 emulation)
>   wsdisplay0: screen 4 added (80x25, vt100 emulation)
> -uhub0: device problem, disabling port 2
> Also note the other changes here. I just saw them in the diff. Don't know
> why or how often they change.
> The CPU is a Core Duo T2300E. It's reported as "unknown Enhanced SpeedStep
> CPU". This shouldn't be hard to fix, but I don't know where to look.

Same on mine.

> I don't know what this "ATK0100 at acpi0 not configured" is. It has a
> Windows driver, but I haven't looked closely. Probably nothing important.
> The ExpressCard slot is untested because I don't have such cards. It doesn't
> show up in dmesg, but this may be normal since according to Wikipedia it
> doesn't have an own controller as CardBus has. Or maybe it is behind the
> unconfigured PCI Express bridge.

My understanding is that these are either connected to a USB2 hub, or
directly to the PCI-Express bus. That's probably normal if it is the
latter; it should show up if it's former.

Mine has got a Cardbus i/f and it works fine.

> There's also a reader for memory cards. It's said to be PCI connected, but I
> didn't see it show up anywhere, even under Windows.


> WLAN is untested,

See above.
> Ethernet works fine.

As fine as a Realtek can work.

> Suspend/Hibernate isn't tested yet.

I tried it once, it wen down, but couldn't come back, so I have so far
abandoned the attempts.

> Here's the dmesg. The kernel is based on GENERIC.MPACPI with some
> unnecessary things removed by adjustkernel and myself.

Presently I run GENERIC.MPACPI unmodified.

> Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006
>      The NetBSD Foundation, Inc.  All rights reserved.
> Copyright (c) 1982, 1986, 1989, 1991, 1993
>      The Regents of the University of California.  All rights reserved.
> NetBSD 4.99.3 (WEBSTERBIS) #2: Sat Nov 11 11:37:44 CET 2006
>         krille@websterbis.lan:/usr/src/sys/arch/i386/compile/WEBSTERBIS
> uhub0: device problem, disabling port 2
> Please remember to CC me on reply.

My other gripe is that I can't get -current to work with the disk
controller in native SATA mode. Both FreeBSD 6.2Beta2 and
OpenBSD-current from 30/10/2006 deal with it properly, whereas for
NetBSD I had to switch to compatible mode. The SATA controller is not
recognized when in AHCI mode. This leads to some 5-8% decrease in disk
i/o benchmarks under Windows, and presumably under NetBSD... It can't
be that hard to get the driver from OpenBSD, but who am I to know...

> Bye, Chris