Subject: audio problems with -current/GCC4?
To: None <,,>
From: John D. Baker <>
List: current-users
Date: 07/08/2006 23:25:56
Cross-posted to each list because it seems relevant in each case...

I've been tracking i386-current for some time and have been successfully
using 3.99.21 built with GCC4 since shortly after it was imported into
the tree.

Most, if not all of my packages, however, were built with GCC3.3.3 that
had been the standard compiler.  They all played very happily together.

When pkgsrc tagged the pkgsrc-2006Q2 branch, I decided I would blow away
all my packages on one particular machine, update pkgsrc on that tag and
build everything from scratch.  As far a building goes, I've only barely
started, but only had one glitch that I've worked around and filed a PR

Then I re-built audio/xmms.  The build itself went without error.  Un-
fortunately, when I try to play any MP3 audio file or stream with it, all
I get is noise.  It otherwise appears to be operating normally.

Since the previous incarnation of xmms was built with GCC3.3.3 and worked
great with my GCC4-built kernel/userland, perhaps there is some problem
with GCC4-built audio applications?  I haven't had a chance to try any
others yet, but I did expect xmms to 'just work'.  (I need to collect
some samples to try with the base userland 'audioplay' tool...)

Has anyone else had problems with audio on i386 when switching from
GCC3.3.3 to GCC4.1.2 to build packages?

John D. Baker, KN5UKS                    NetBSD     Darwin/MacOS X
jdbaker(at)mylinuxisp(dot)com                 OpenBSD            FreeBSD
BSD -- It just sits there and _works_!
GPG fingerprint:  D703 4A7E 479F 63F8 D3F4  BD99 9572 8F23 E4AD 1645