Subject: Re: bootable kernel with embedded filesystem
To: Brook Milligan <>
From: Hubert Feyrer <>
List: current-users
Date: 07/08/2006 23:56:54
On Sat, 8 Jul 2006, Brook Milligan wrote:
> To track this down further, I tried booting just the kernels directly
> from a hard disk.  GENERIC_LAPTOP boots fine, whereas INSTALL_LAPTOP
> with the filesystem image installed does not.

Was that INSTALL_LAPTOP the one from 
src/sys/arch/i386/compile/INSTALL_LAPTOP (i.e. w/o the ramdisk) or from 
src/distrib/i386/instkernel (i.e. the one that has the ramdisk embedded)?
I could imagine the former one to explode when it tries to mount "root on 
md" when there's nothing at md, but the latter should work.

BTW, knowing what the last few lines before the explosion are would be 
useful. Can you boot the bootcd-com.iso and see what the last few lines 
are before crashing? Maybe you can run this in qemu (-nographic for 
cut&paste) and get the same error... it's easier to debug.

> Does anyone have any ideas on how to track down the problem?  Do I
> need to try identical kernels, one with and one without an embedded
> filesystem?

You can always try making a GENERIC kernel with a ramdisk too,
or transmogrifying the INSTALL_LAPTOP into a GENERIC kernel while keeping 
the ramdisk, and see where it fails.

> Would someone be willing to check out the sources with the date
> "2006-07-07 00:00:00 UTC", build the INSTALL_LAPTOP kernel with the
> embedded filesystem (I did this with ' release'), and try to
> boot it?

No fast machine for such experiments, sorry.

  - Hubert