Subject: reproducible crash with 3.99.13
To: None <>
From: Jukka Salmi <>
List: current-users
Date: 12/03/2005 18:03:51

I just tried this on two different systems (both running NetBSD/i386
3.99.13) with the same result:

- connected to a remote site using vpnc (version 0.3.3)
- mounted a smb file system from a host on that remote site
- cd to into the newly mounted file system hierarchy
- copied a file to my local ffs ->

uvm_fault(0xcaa68540, 0, 0, 1) -> 0xe
kernel: supervisor trap page fault, code=0
Stopped in pid 2031.1 (cp) at	netbsd:uvn_findpage+0xc:	movl	0(%eax),%eax
db> tr
uvn_findpage(cbd16f28,0,0,0,0) at netbsd:uvn_findpage+0xc
uvn_findpages(cbd16f28,0,0,cba7892c,0) at netbsd:uvn_findpages+0xaf
genfs_compat_getpages(cba78980,1,cbd16f28,0,c06453a0) at netbsd:genfs_compat_getpages+0x102
VOP_GETPAGES(cbd16f28,0,0,0,cba78a04) at netbsd:VOP_GETPAGES+0x52
ra_startio(cbd16f28,0,0,80000,0) at netbsd:ra_startio+0x63
uvm_ra_request(cbd13cdc,2,cbd16f28,0,0) at netbsd:uvm_ra_request+0x16a
uvn_get(cbd16f28,0,0,cba78b08,cba78b0c) at netbsd:uvn_get+0xaa
uvm_fault(caa68540,bba1e000,0,1,2) at netbsd:uvm_fault+0xa3b
trap() at netbsd:trap+0x31f
--- trap (number 6) ---
i386_copyin(caa6c4cc,bba1e000,cb0fb000,2000,0) at netbsd:i386_copyin+0x3b
uiomove(cb0fb000,2000,cba78ec4,2000,ffffe000) at netbsd:uiomove+0xde
ffs_write(cba78e24,4391c6f4,cba78e5c,c03fe5d0,c0644c20) at netbsd:ffs_write+0x3d3
VOP_WRITE(cbd167f0,cba78ec4,10,caa60000,cbd167f0) at netbsd:VOP_WRITE+0x34
vn_write(caa77384,caa773b0,cba78ec4,caa60000,1) at netbsd:vn_write+0xc2
dofilewrite(caa6c4cc,5,caa77384,bba1e000,ff4f0) at netbsd:dofilewrite+0x81
sys_write(caa6b000,cba78f64,cba78f5c,0,c044cff1) at netbsd:sys_write+0x51
syscall_plain() at netbsd:syscall_plain+0x7e
--- syscall (number 4) ---
db> sync
syncing disks... panic: lockmgr: locking against myself
Stopped in pid 2031.1 (cp) at	

Please tell if I should provide more information and/or file a PR.

TIA, Jukka

bashian roulette:
$ ((RANDOM%6)) || rm -rf ~