Subject: Re: Threading/DNS issues with 2.1RC3?
To: , <>
From: David H.Gutteridge <>
List: current-users
Date: 09/08/2005 00:03:17
The problem is indeed that the resolver functions aren't re-entrant in
2.1.  There was a patch (batch-br) for Mozilla, Firefox, and Thunderbird
(as I noted I'd looked at before), but because it used the old release
numbering scheme to figure out whether it was applicable, it wasn't being
compiled in under 2.1.  (See my original reference below, I was right
about the patch, but wrong about how I altered it the last time I tried
a compile.)

So, until pkgsrc gets fixed, anyone trying to compile these browsers or
related ones like Epiphany should alter patch-br so the version number it
references is < 299000000 rather than < 200060000.


> From: David H. Gutteridge <>
> Date: 2005/09/05 Mon AM 12:41:08 EST
> To: <>, <>
> Subject: Threading/DNS issues with 2.1RC3?
> Hi all,
> Just wondering if anyone else is testing the 2.1 RCs (I've got RC3 running right
> now for i386) and has noticed what appear to be problems with threading and/or
> DNS lookups which cause applications to hang (so to speak)?
> I'm consistently getting hangs when I try and do anything intensive with multi-
> threaded web browsers like Firefox, Epiphany (same thing I guess), and Dillo.
> When I try opening multiple sites within or between them, things quickly grind
> to a halt, the common denominator being DNS queries which don't return.
> When I look at what's going on with netstat -na, I see things like this:
> udp        0      0
> udp        0      0
> udp        0      0
> (The foreign address is my local DNS server, and there's nothing wrong with it.
> In fact, the UDP packets appear not to be getting to it at all.)  These sockets
> remain in this state for the life of whatever app opened them.  If I look at
> processes with top, I see the processes in question are typically in the netio
> state.
> All three of those browsers happen to be multi-threaded (Dillo uses threading for
> DNS queries); if I crack open lynx or the command-line ftp client, I have no
> trouble resolving the same sites that the "big" three are stuck on, and can
> conduct things normally.  I can run the very same applications with the same
> usage pattern on another box I have running i386/2.0.2 without incident, and
> they're all identical versions from pkgsrc.
> I tried ktracing a Firefox session, but couldn't see anything revealing
> (but I can't claim expertise in this area, so that doesn't mean anything
> necessarily).  I haven't built anything with debugging symbols, but will try
> that and see what I can get if this isn't an issue that's already been
> identified.  I'd thought I'd found the problem
> (see:, but that
> doesn't seem to be it.
> Regards,
> Dave