Subject: How to rebuild the world
To: None <>
From: Julio Merino <>
List: current-users
Date: 12/27/2001 23:23:54
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Hi all

yesterday I got and installed a -current snapshot: 20011222-1.5ZA. This
is the first time I see a current netbsd branch and... it is great!!
I've only used 1.5 and 1.5.1... but the system is going even better! :)
BTW, I'm on i386.

Well, I got the sources with cvs and after a bit of trouble, I've
compiled my own kernel, which works so well... ;)

Ok, now it's time to build the world. And I can't get it. So far, I've
added the following to /etc/mk.conf:
COPTS+=3D-O2 -pipe -march=3Dpentiumpro
NBUILDJOBS=3D4 <-- a single cpu, but this gives better performance to me
USE_NEW_TOOLCHAIN=3Dyes  <-- tried with yes and no and undefined
OBJMACHINE=3Dyes <-- tried with this and without
MKOBJDIRS=3Dyes  <-- tried with this and without

I go to /usr/src and issue:
# ./buildsh -d
I've also tried:
# make build

It starts doing things and it breaks when doing the 'cleandir'. I can't
remember where exactly it breaks... :( Well, I think this problem is
because I've broken my source tree; I'm refetching it, just to be safe.

But I also had another problem. It complains about a missing 'binstall'.
Yep, it's nowere. I've been looking into the source tree, and I can't
find it. What's up with this???

I've readed the "Tracking NetBSD-current" document from the website,
the BUILDING and UPDATING files from /usr/src, but I can't get this to

Any idea?
Thanks a lot!

La ignorancia es la felicidad.

Julio Merino (Slink) <>

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.0.6 (FreeBSD)
Comment: For info see