Subject: Another umass issue (Olympus D-100 camera)
To: None <>
From: Nathan J. Williams <>
List: current-users
Date: 12/14/2001 14:33:15
I tried using the USB connection of a new Olympus D-100 camera to read
a SmartMedia card of pictures. It didn't quite work on my iBook, under
today's -current, with rev 1.76 of umass.c.

Attach looks so-so:

umass0 at uhub1 port 1 configuration 1 interface 0
umass0: OLYMPUS C-1, rev 1.10/10.62, addr 2
umass0: using SCSI over BBB
scsibus0 at umass0: 2 targets, 1 luns per target
scsibus0: waiting 2 seconds for devices to settle...
sd0 at scsibus0 target 1 lun 0: <OLYMPUS, C-1, 1062> SCSI2 0/direct
sd0: mode sense (4) returned nonsense; using fictitious geometry
sd0: 16000 KB, 15 cyl, 64 head, 32 sec, 512 bytes/sect x 32000 sectors
sd0: mode sense (4) returned nonsense; using fictitious geometry

Running "disklabel sd0" produced the following kernel message:

sd0(umass0:0:1:0):  Check Condition on CDB: 0x08 00 00 00 01 00
    SENSE KEY:  Illegal Request
     ASC/ASCQ:  Invalid Command Operation Code

sd0: I/O error reading block zero

but a dimly-reasonable fictitious geometry:

3 partitions:
#        size    offset     fstype  [fsize bsize cpg/sgs]
 c:     32000         0     unused      0     0         # (Cyl.    0 - 15*)

I saw that there was a quirk specifically for the C-1 camera engine in
umass.c already, and while disabling that does make things worse (lots
of "umass0: Invalid CSW: sig 0x55425355 should be 0x53425355"), it's
still not quite functional.

Any ideas? What debug flags or tweaks should I try next?

        - Nathan