Subject: Uh, need help programming: what causes this kdc error?
To: None <>
From: None <>
List: current-users
Date: 12/11/2001 20:34:16
I'm working on getting Zephyr running with Kerberos on NetBSD 1.5.2
(on an Alpha, if it matters). 

I had to beat up the Zephyr package a bit to get it to compile. I'll
submit patches when I get this thing running.  (That's my attempt
at being somewhat on topic. Sorry if it's too much of a stretch!)

The problem I'm having is that when I run a kerberos-enabled zwgc
talking to a kerberized zhm (and zephyrd) I get this error in my
kdc.log file:

2001-12-11T20:20:37 Ticket-granting ticket not found in database: krbtgt.INT.NEUTRALGOOD.ORG@: No such entry in the database

I get two of these errors, once when zwgc announces it's location, and
another when it tries to subscribe to anything. Nothing comes across.
I turned on debugging of libkrb (there's a call for that) and this
is what I get:

Machine time: Tue Dec 11 20:28:30 2001
Correcting to Tue Dec 11 20:28:30 2001
Authent->length = 137
Getting host entry for it.
connecting to ( udp, port 750
sending 156 bytes to (, udp port 750
recieved 118 bytes on udp/tcp socket

The serv= and princ= items look a bit fishy but I don't know what caused

I'm in the middle of recompiling libc so I can recompile libkrb so I
can add debugging statements. It takes a while on an LCA box. Any
suggestions? I'd much appreciate it. 

(While I'm here: has anyone tried the krb5-xdm from the Kerberos 5 AFS
Migration kit?)
Kevin P. Neal                      

"Nonbelievers found it difficult to defend their position in \ 
    the presense of a working computer." -- a DEC Jensen paper