Subject: Re: ffs crash after raid reconfiguration
To: Greg Oster <>
From: Kazushi (Jam) Marukawa <>
List: current-users
Date: 07/21/2001 13:12:43
   On Jul 21, 11:54, Greg Oster wrote:
   > Subject: Re: ffs crash after raid reconfiguration
   > Kazushi Marukawa writes:
   > > Anyway, what I wanted to say was this.  Both time, RAIDframe
   > > failed to configure.  I changed the configuration file and
   > > manually reconfigured them.  I mean that I changed
   > > /etc/raid0.conf and executed "raidctl -c /etc/raid0.conf
   > > raid0".  For example, I can reboot the machine at this time.
   > > However, both time I didn't reboot the machine.  I just
   > > configured, fscked (if it's necessary), mounted, and
   > > continued the system.  Then, system was crashed.  So, I was
   > > wondering it might work without crash if I rebooted the
   > > system.
   > A reboot isn't necessary.  You should be able to configure/unconfigure 
   > a RAID set as many times as you'd like without a reboot.

I thought so, but it was crashed twice.  I've never seen
this kind of crash in regular operation, so I was just
wondering and afraiding, then telling you it with a hope you
may find something.  Thanks.

   > I'm just wondering why it said that wd4e failed after you removed a
   > drive from the system -- if the failed drive was removed, it shouldn't
   > be finding another failed drive!   You used '-c' (and not '-C') in the  
   > 'raidctl -c /etc/raid0.conf raid0', right?  If the autoconfig didn't
   > work, then the 'raidctl -c' shouldn't have worked either... 
   > Also: what were the exact changes you made to /etc/raid0.conf, and can
   > you send me the full output of 'raidctl -s raid0'. 

Yes.  "-c" worked.  I'll send a copy of those information as
private message later.

-- Kazushi
Science is what happens when preconception meets verification.