Subject: -current libc Alpha issue?
To: None <>
From: Michael G. Schabert <>
List: current-users
Date: 07/10/2001 10:00:59
Hi all,
AlphaStation 4/200 166 1.5W, sitting at my office (static IP DSL)

I have cron scripts set to make build weekly, doing incremental 
builds (update). I noticed that Friday my alpha suddenly became 
unresponsive (after while of churning for the update)...Apache still 
served web pages, but qpopper wouldn't work & when I tried to telnet 
in, the window would pop onto my screen & then disappear. I hooked up 
as console & it asked me to Login, so I typed in root, & then it 
paused a few seconds & then flashed back to Login:. I unceremoniously 
sent a break, & rebooted from the debugger. I halted the boot & told 
it to boot in interactive mode, to boot single-user. That got me in, 
but many commands segfaulted on me. It even segfaulted when I tried 
to "tail" the file in the /var/spool/mqueue to see where it got in 
the build process. When I finally got a view of that file, I saw that 
it dumped while doing the install of libc:

install ===> libc
install -r -p -c  -o root  -g wheel -m 600 libc.a /usr/lib/libc.a
ranlib -t /usr/lib/libc.a
chmod 444 /usr/lib/libc.a
install -r -p -c  -o root  -g wheel -m 600 libc_p.a /usr/lib/libc_p.a
ranlib -t /usr/lib/libc_p.a
chmod 444 /usr/lib/libc_p.a
install -r -p -c  -o root  -g wheel -m 600 libc_pic.a /usr/lib/libc_pic.a
ranlib -t /usr/lib/libc_pic.a
chmod 444 /usr/lib/libc_pic.a
install -r -p -c  -o root  -g wheel -m 444 /usr/lib/
ln -sf /usr/lib/
mv -f /usr/lib/ /usr/lib/
ln -sf /usr/lib/
mv -f /usr/lib/ /usr/lib/
install -r -p -c  -o root  -g wheel -m 444 llib-lc.ln /usr/libdata/lint
*** Signal 11

make: stopped in /usr/src/lib/libc
*** Error code 1

So, to fix, I happened to still have snapshot tarballs in /, so I did 
a tar -zxpf base.tgz & rebooted. Everything worked after that. I made 
a brand new kernel & rebooted yet again, & rescheduled the make build 
for Saturday night into Sunday. Well, Sunday I telnetted into the 
Alpha & saw that the build completed just fine. I made yet another 
kernel & never came back online. When I got into the 
office today, I hooked into serial console & saw the following 
scrolling down my screen
Process (pid 1) got signal 11
Process (pid 1) got signal 11
Process (pid 1) got signal 11
Process (pid 1) got signal 11
Process (pid 1) got signal 11
Process (pid 1) got signal 11
Process (pid 1) got signal 11

Sending a break didn't do anything (prolly hafta time it just right 
to sneak it in there), so I hit the reset button & tried to boot in 
SU mode. That didn't work, nor did booting SU into the older kernel 
that worked before (they all give the same scrolling). Of course, the 
floppy drive for the Alpha is at home while the computer & myself are 
here at work, & I don't happen to have a netboot setup here (although 
I'm working on that as soon as I fire out this message)

Any clues as to why this newer libc doesn't want to play nice with my 
just-as-current-as-libc kernel? Is it another issue entirely? Should 
I risk a make clean & make build when I get up again, or will it 
likely return me to the same state?

Any info would be greatly appreciated,
Michael G. Schabert, Mac Guy
Miranda Graphic Systems, publishers of Graphic Power