Subject: Re: Web load causes reboot
To: Frank van der Linden <>
From: Koos de Haan <>
List: current-users
Date: 08/04/1999 11:26:45
Op 23:58 +0200 03-08-1999, Frank van der Linden schreef:

> On Tue, Aug 03, 1999 at 12:59:56PM -0700, Len Burns wrote:
> > On Tue, 3 Aug 1999, Manuel Bouyer wrote:
> > 
> > > On Tue, Aug 03, 1999 at 05:00:34PM +0200, Koos de Haan wrote:
> > > > There is no coredump. The machine reboots without any warning.
> > > 
> > Indeed it is.  I can reproduce the same behavior here using a 1.4.1
> > kernel on i386.  
> Could either of you give some more data, like the configurations
> of your system, the type of network that you're using, the client
> that the Apache bench program is run on (i.e. how fast is it), and
> the size of the file that is being transferred with each request?
> And perhaps the types of ethernet card that you are using.
> I've tried to reproduce it, but so far without success. The mbuf
> allocation code did give me the usual "WARNING: mclpool limit reached;
> increase NMBCLUSTERS" (I had put nmbclusters at 4096), but no crash.
> This was with the server on a PIII-450, with the client on a P5-133,
> talking to eachother over a 3com 905B and an i82558. I also
> tried using localhost on the PIII-450, still no crash.
> I'd love to reproduce and fix it, because it's a serious bug that
> has been plagueing people using 1.4 or later a lot.
> - Frank

Hi Frank,

Server :
PIII 450 with 512 Mbyte of RAM, 
3c905B NIC 
SCSI harddisk attached to a Adaptec 2940. 
The mainboard is Asus P-2BF.
The Nic isn't the problem, the problem also appears when i use the ZNYX 346 card (DEC chipset) .
OS : NetBSD-current

Clients :
PIII 450 with 512 Mbyte of RAM,
ZNYX ZX346 DEC 21140A Chip
SCSI harddisk attached to a Adaptec 2940. 
The mainboard is Asus P-2BF.
O.S : Redhat Linux 6.0 or NetBSD 1.3.2

The server and client are connected to a 100 Mbit Switch, when i place the server in a 10 Mbit segment of the network the problem also appears.

I tested from a Linux client and a NetBSD 1.3.2 client. Both giving the same results. The ab program (ApacheBench) is version 1.3, this version comes with the 1.3.6 apache distribution.
When i test from a sparc SS20 with a 10 mbit interface running NetBSD 1.4 it takes some more time (read more http requests) to get the server crashing. 
With the GENERIC kernel i did get the "WARNING: mclpool limit reached" message. After increasing the NMBCLUSTERS to 4096 in the kernel the message doesn't appear, but the server reboots as in the other cases

When i test from the localhost the server reboots also after some time, but only when the connection rate is high enough : 

# ulimit -n 255
# ./ab -n 10000 -c 240  

The size of the file (index.html) requested is 419 bytes in all cases.


Koos de Haan

Here is also the dmesg output of the server :

NetBSD 1.4I (GENERIC) #0: Wed Aug  4 10:16:16 CEST 1999
cpu0: family 6 model 7 step 2
cpu0: Intel Pentium III (686-class)
total memory = 511 MB
avail memory = 471 MB
using 2822 buffers containing 26296 KB of memory
mainbus0 (root)
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o enabled, memory enabled
pchb0 at pci0 dev 0 function 0
pchb0: Intel 82443BX Host Bridge/Controller (rev. 0x03)
ppb0 at pci0 dev 1 function 0: Intel 82443BX AGP Interface (rev. 0x03)
pci1 at ppb0 bus 1
pci1: i/o enabled, memory enabled
vga1 at pci1 dev 0 function 0: ATI Technologies product 0x524c (rev. 0x00)
wsdisplay0 at vga1: console (80x25, vt100 emulation)
pcib0 at pci0 dev 4 function 0
pcib0: Intel 82371AB PCI-to-ISA Bridge (PIIX4) (rev. 0x02)
pciide0 at pci0 dev 4 function 1: Intel 82371AB IDE controller (PIIX4)
pciide0: bus-master DMA support present
pciide0: primary channel wired to compatibility mode
pciide0: disabling primary channel (no drives)
pciide0: secondary channel wired to compatibility mode
pciide0: disabling secondary channel (no drives)
uhci0 at pci0 dev 4 function 2: Intel 82371AB USB Host Controller (PIIX4) (rev.
uhci0: interrupting at irq 10
uhci0: USB version 1.0
usb0 at uhci0
uhub0 at usb0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
Intel 82371AB Power Management Controller (PIIX4) (miscellaneous bridge, revisio
n 0x02) at pci0 dev 4 function 3 not configured
ex0 at pci0 dev 9 function 0: 3Com 3c905B-TX 10/100 Ethernet
ex0: interrupting at irq 10
ex0: MAC address 00:a0:24:45:fa:2d
exphy0 at ex0 phy 24: 3Com internal media interface
exphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
ahc1 at pci0 dev 12 function 0
ahc1: interrupting at irq 11
ahc1: aic7880 Wide Channel, SCSI Id=7, 16 SCBs
scsibus0 at ahc1 channel 0: 16 targets, 8 luns per target
ahc1: target 0 using 16Bit transfers
ahc1: target 0 synchronous at 20.0MHz, offset = 0x8
sd0 at scsibus0 targ 0 lun 0: <QUANTUM, VIKING II 4.5WLS, 5520> SCSI2 0/direct f
sd0: 4350 MB, 8338 cyl, 5 head, 213 sec, 512 bytes/sect x 8910423 sectors
isa0 at pcib0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
lpt0 at isa0 port 0x378-0x37b irq 7
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
sysbeep0 at pcppi0
isapnp0 at isa0 port 0x279: ISA Plug 'n Play device support
npx0 at isa0 port 0xf0-0xff: using exception 16
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
isapnp0: no ISA Plug 'n Play devices found
biomask c40 netmask c40 ttymask cc2
boot device: sd0
root on sd0a dumps on sd0b
root file system type: ffs


Kabelfoon BV
Industriestraat 30, Postbus 45, 2670 AA  NAALDWIJK
Tel. 0174-640269, fax 0174-623860
e-mail voor informatie, voor abonnementszaken, voor de helpdesk
Zie voor Kabelfoon public keys