Subject: Recent changes hang during startup?
To: MacBSD List <port-mac68k@NetBSD.ORG>
From: Paul Goyette <>
List: current-users
Date: 02/17/1997 15:26:27
OK, folks, I got the latest sup from today (including the very latest
version of vm/vnode_pager.c) and rebuilt my kernel.  Everything builds
fine, but the system hangs during multi-user startup, right in the middle
of running fsck!

I can fsck the disks individually, and it works OK.  But when the
automatic fsck runs, it hangs right after completing the second partition
(ie, after the first partition in pass #2, per /etc/fstab).

Also, I booted this same kernel in single-user, and mounted /usr ('cuz I
wanted to edit /etc/fstab with vi).  This worked OK, but when I cd'd back
to / and tried to umount /usr, it claimed that the device was busy!  I
_know_ for sure that I didn't have any files open on it, and my cwd wasn't
pointing to it,so why couldn't I unmount it?

For now, I'm back to a kernel built using last Tuesday's -current and all
is well....