Subject: Re: Trying to XCompile a mac68k kernel - solved
To: None <current-users@NetBSD.ORG>
From: Bill Studenmund <>
List: current-users
Date: 02/03/1997 19:31:56
Wow! Thanks for all the quick responses!

I went with Chris Demetriou's suggestion, which was basically to use instead of lorder.

Also, I'm wondering if I'm doing something wrong. I'm using the
m68k-apple0netbsd-X versions of gcc, as, ar, ranlib, and nm explicitly. 
I.E. the kernel Makefile has "AS= /xmac/bin/m68k-apple-netbsd-as" in it
(which is really the netbsd one w/ a patch I was sent, set to cross

The main reason I did this is I don't like path dorking. Instinctively
target=i386 some of the time, and target=m68k some of the time is
unsettling. Especially as 1) I occasionally forget to set the paths or
env. variables, 2) the mac68k kernel compiles a program (genassym.c) to
run on the HOST (maybe the genassym.awk program'd help), and 3) shell
programs, if well written, reset the path to a known value. :-)

I mention all this as lorder is the only real stickler I ran into.
Excessive MACHINE_ARCH=m68k made everything seem to work, but lorder has
an explicit call to nm. Since I'm not great at sh programming, I didn't
see a way to do something as flexable as the environment variable stuff in
make files.

My solution was to make lorder.i386, and lorder.m68k, and to change the
calls to it to be lorder.${MACHINE_ARCH}.

lorder hasn't changed between 1.2 and current. Is there a better way to do
this? Should I send-pr it?