Subject: Re: for perl5.001 ?
To: None <>
From: Lon Willett <>
List: current-users
Date: 04/19/1995 05:54:16
    >> Anyone got a perl5.001/ that worked (passed all tests)
    >> under -current?

    > ...

    >> i got similar results, and i'm looking in to it at the moment.
    >> but i have not worked out what is happening (perl is dumping core
    >> in dlopen()) ..

    > I got a copy of from Greg Earle who reports that on
    > netbsd-1.0-sparc it worked ok.  Comparing his and mine the
    > only significant difference was that Greg did not use dynamic
    > loading.  Note that most if not all the tests that failed
    > relied on dynamically loaded extensions.

    > ... If some one does get the dynamic loading working - please let
    > me know.

Curious.  I had no problems with perl5.001 on current/{i386,sparc},
even with dynamic loading enabled.  I've made some changes to the
source, but even the initial test I did before I made my mods, with
just the default netbsd setup for perl, passed all the tests handily.

Are your libraries/gas/ld/gcc up to date?

Maybe some kernel option is at fault.  I use the options SETUIDSCRIPTS
and INSECURE, as well as various COMPAT options.

If you don't have SETUIDSCRIPTS set, then I think that perl is compiled
differently, so this is a real possibility.

--Lon Willett