Subject: MH 6.8.3 "-watch" switch not working under NetBSD 1.0/-current?
To: None <NetBSD-users@NetBSD.ORG, current-users@NetBSD.ORG>
From: Greg Earle <earle@isolar.Tujunga.CA.US>
List: current-users
Date: 04/05/1995 17:02:22
I'm using MH 6.8.3 on both NetBSD/SPARC 1.0 and SunOS 4.1.4; on the former
I used cgd's "MH" config file that he put out a while back.

The "-watch" switch is supposed to be somewhat like the "-v" switch to "Mail";
i.e. let you watch the MH "post" <-> "sendmail" transaction.  This is working
fine for me under SunOS 4.1.4, but I get nothing under NetBSD:

SunOS 4.1.4:

What now? send -watch
<= 220 isolar.Tujunga.CA.US Sendmail 4.1/SATAN-6.6.6 ready at Wed, 5 Apr 95 16:27:00 PDT
<= 250 postmaster... Sender ok
=> RCPT TO:<>
<= 250 <>... Recipient ok
<= 250 Mail accepted
<= 221 isolar.Tujunga.CA.US delivering mail

isolar:1:30 [/var/spool/uucp/elroy] % send -help
version: MH 6.8.3 #1[UCI] (isolar) of Tue Dec 13 23:06:23 PST 1994
options: [ATTVIBUG] [BIND] [BPOP] [BSD42] [BSD43] [FLOCK]
         [FOLDPROT='"0700"'] [MHE] [MHRC] [MIME] [MIME] [MSGID]
         [MSGPROT='"0600"'] [NFS] [NNTP] [OVERHEAD] [RENAME] [RPATHS]
         [SENDMTS] [SMTP] [SUN40] [TYPESIG=void] [UCI] [VSPRINTF]


What now? send -watch
netbsd4me:1:61 % 

netbsd4me:1:61 % send -help

version: MH 6.8.3 #4[UCI] (netbsd4me) of Fri Jan 20 20:39:16 PST 1995
options: [BIND] [BSD42] [BSD43] [BSD44] [DBMPWD] [FLOCK] [MHE] [MHRC]
         [MIME] [MORE='"/usr/bin/more"'] [NORUSERPASS] [NTOHLSWAP]
         [OVERHEAD] [POP] [POP2] [POPSERVICE='"pop3"'] [POSIX] [RPOP]

If I run "post" directly it still doesn't work:

netbsd4me# post -watch /tmp/draft

Everything else I've used in MH under NetBSD seems to be working just fine,
so I'm kinda curious about this one.  Anyone else see this?  (I don't yet
have a -current system to test this on; however, I suspect it's not a
problem with the O/S rev., necessarily.)  

	- Greg