Subject: Re: Shared X and an error...
To: Frank van der Linden <>
From: Ji <>
List: current-users
Date: 12/14/1993 10:34:21

> This kind of thing is a problem with the NetBSD shared libraries, or
> should I say was. Paul Kranenburg added a (heuristic) patch to ld
> to take care of this kind of thing (being libXt) some time ago. Recompiling
> libXt / the application with the newer ld solved this kind of problem for me
> (like the 'unexpected end of ... segment' (?) error someone reported
> in libXmu on this list lately; I had that too, with xpaint, but a recompile
> of libXmu with the latest ld fixed it).
> So it could be that either you, or the one who had made the shared libraries
> had an older ld version.
> gcc and gas have been modified to generate type info on symbols, to make
> it possible for ld to handle these things properly, and I think that ld will
> change soon too which (according to Paul Kranenburg, who is doing all this
> work) will create some backward incompatibilities.
> - Frank

Thanks for the information. So shared libraries won't work with my version.. 
so I thought I would compile the X application using -static. Everything
compiles but then I when I try to start the application, I get

Error: Could not open display :0.0

!!!! The other X application suffers from exactly the same problem! I tried
switching to NetBSD0.9 ld/crt0.o/gcrt0.o but the same error occurs.
Do I have to give ld another option other than -static to get it to link 
using the static libraries?

Has anyone compiled an X application statically using the new gcc/ld/etc