Subject: Re: Loss of job control in current?
To: Charles Hannum <>
From: Michael L. VanLoon -- Iowa State University <>
List: current-users
Date: 11/21/1993 13:11:12
>   But when I ^Z editors under current (what looks to be the Nov 7
>   current tar files), I lose all control over them when I bring them
>   back to the foreground.

>1) Define `lose all control'.

The screen doesn't refresh when I foreground the editor.  Things I
type aren't consistently honored by the editor -- ^C acts weird, ^L
doesn't refresh, ESC doesn't work at all, etc...  If I ^Z it again at
this point, it often looks like two suspended jobs, not just one.

>2) I could not reproduce any problem with suspending Emacs.

Which emacs are you running and how did you compile it?  I haven't
been able to rebuild emacs yet with shared libs -- it's crt0 doesn't
play nicely with current shared libs.  I haven't tried rebuilding it
with static links cause I already have one linked that way and it
wouldn't give me anything I don't already have.

>3) Are you *sure* the job control in your tcsh isn't broken?

Well, I couldn't swear by it, but:

  - This very same tcsh executable worked flawlessly under 0.9 (it was
    compiled under a stock 0.9 system).  This tcsh executable has
    handled job control perfectly under stock 0.9 for months.
  - I haven't ever seen this problem til upgrading everything to
  - Building a new tcsh under current doesn't fix the behaviour.

Since the tcsh was working just dandy with job control under stock
0.9, that's why it leads me to believe it's something strange in
current.  Has there been much change with tty handling in the current

    Michael L. VanLoon  --  --  gg.mlv@isumvs.bitnet
 Iowa State University of Science and Technology -- The way cool place to be!
   Project Vincent Systems Staff, Iowa State University Computation Center