Subject: spontaneous reboots while building current libs
To: None <>
From: Michael L. VanLoon -- Iowa State University <>
List: current-users
Date: 11/16/1993 23:59:16
I've been running vanilla 0.9 for some time now with no real problems.
Recently I decided to upgrade to current to get ppp and shared libs.
But, while trying to do a make in /usr/src/lib I keep getting
spontaneous reboots.  Here's what I've done:

  - extracted all the latest current tar files on top of my src tree
  - extracted someone's pre-packaged shlib-bootstrap files onto my
    system which included a new gcc/cc, as, ld, and shared libc and
  - made and installed the share/mk stuff
  - made and installed the current src/include
  - made and installed a new crt0
  - made and installed a new mkdep

At this point I went into /usr/src/lib and did make.  It churns away
for awhile compiling then spontaneously reboots.  I start it again
from where it left off, it churns away some more, then reboots again.
I've tried all sorts of shell limit values and nothing makes a

I then grabbed the all the libraries off my office-mate's
( machine, who is running current, as well as
grabbing his gcc, as, and ld.  Then I rebuilt crt0 again.

Same result.  Make churns for awhile, compiling a few object modules,
then the machine reboots.

Can anyone shed any light onto possible causes?

If it matters: ALR BusinessVeisa 366dx33, 64k cache, 10meg RAM, 2
Conner CP3104 100meg IDE hard drives (both are completely NetBSD),
WD8013EBT ether card (compiles were via telnet).

I've never had it behave like this until I started doing things with
the current-compiled gcc/ld/as and libraries.


    Michael L. VanLoon  --  --  gg.mlv@isumvs.bitnet
 Iowa State University of Science and Technology -- The way cool place to be!
   Project Vincent Systems Staff, Iowa State University Computation Center