Subject: Three Current Problems
To: None <>
From: John F. Woods <>
List: current-users
Date: 11/16/1993 14:47:12
(1) I tried building the XFree86 2.0 distribution last night, and the
servers didn't compile (though the log file claimed the entire build
finished successfully).  I eventually tracked it down to the header
file mit/server/ddx/x386/os-support/xf86_OSlib.h including two header
files that no longer appear to exist:  <machine/ioctl_pc.h> and
<machine/console.h>.  Have I just somehow missed installing these, or
is there an update to xf86_OSlib.h that I lack?  I also couldn't see
any trace of support for the VT_ virtual terminal ioctls in the
current kernel sources.  What am I missing?

(2) My kernel didn't build right off, complaining that
"../../../../lib/libkern/libkern.a" didn't exist.  Well, of course
not; having done "make obj" in /usr/src, make appears to have arranged
for a /usr/src/lib/libkern/obj/ directory to exist, where libkern.a
was to be found.  (I just added a symbolic link, not knowing what
needs to be corrected.)

(3) The Nov 12 kernel doesn't like my ethernet adapter configuration;
it is an SMC Elite 16, set up for REG=300, RAM=CC000, IRQ=9.  It turns
out that my kernel config file specifies irq 10, and the if_ed
initialization code gripes about the mismatch and fails to configure
the device (and if I config for irq 9, it collides with a serial port.
Whoops!).  This must be a recent change; my previous (two-week-old)
kernel worked fine--presumably it just told the adapter to use irq 10
instead.  If that's the case, and if the removal of that feature was
deliberate (perhaps owing to some deficient board somewhere that won't
change its irq?), does anyone happen to know if the "software
configuration" capability of the SMC Elite stores the configuration in
an EEPROM, or will I have to detour through DOS (ulch!) every time I
power cycle?

John,, (where the NetBSD is)