Subject: adventures with current! :-)
To: None <>
List: current-users
Date: 11/13/1993 04:16:57

	I'm still working on getting current to build, and seem to be
	getting a little farther along in things:

	I've got a current source tree up until about 8pm Friday

	I do the following:

	cd /usr/src/share/mk; make install
	cd /usr/src/include; make && make install      (*)
	setenv LDSTATIC -static
	setenv NOPIC
	cd /usr/src/lib/libc; make && make install
	(*) the libc build fails initially because the include make install
	doesn't copy over some new regex.h file.  When I copied this
	from /usr/src/include to /usr/include, things worked fine for

	cd /usr/src/gnu/lib/libmalloc; make && make install
	cd /usr/src/gnu/usr.bin/gas; make && make install
	^=This fails with the error:

/usr/lib/crt0.o: Undefined symbol __DYNAMIC referenced from text segment
/usr/lib/crt0.o: Undefined symbol __DYNAMIC referenced from text segment
*** Error code 1

	gnu/usr.bin/ld and gcc2 both also fail on the exact same error.
	I then went to /usr/src/lib/csu/i386 and did a make && make install
	there, and it put a new crt0.o in /usr/lib, but the exact same
	problem persists. (with clean builds)

	Again, I am still using the generic 0.9 kernel (which I've
	been told is entirely sufficient)  I am still using plain vanilla
	0.9 utilities and all that stuff.  I'm just trying to get going to
	current in one shot :-)

	Thoughts on where to go from here?


						Marc 'em.

Marc Wandschneider					    Seattle, WA
Barney the Dinosaur sings! You faint... Barney sings!  Barney sings! --More--
You Die... --More--