Subject: None
To: Marc Wandschneider <>
From: Chris G. Demetriou <cgd@nobozo.CS.Berkeley.EDU>
List: current-users
Date: 11/11/1993 22:31:40
> 	gas would not build because it got undef'd external __tolower_tab_
> 	or something like that.
> 	gcc wouldn't build because it couldn't find libgnumalloc.a
> 	ld wouldn't build because it couldn't find libgnumalloc.a

ok, then you had to reinstall the libs.

> 	Being quick to see things, I then decided it might be worth
> 	going to /usr/src/gnu/lib and doing a make && make install
> 	there.
> 	libgnumalloc dies with:
> /u0/src/os/src/gnu/lib/libg++/libg++/CursesW.h: In method `int  CursesWindow::begx ()':
> /u0/src/os/src/gnu/lib/libg++/libg++/CursesW.h:346: structure has no member named `_begx'
> [ ...]

umm, that's libg++, not libgnumalloc.
if you'd just made and installed libgnumalloc, it would have worked.

the libg++ thang was a problem because of the new curses; as promised,
i've fixed all of those bugs now (libg++ was the last thing with
a problem, and i fixed it today...).  (*chuckle*  even with prior
notice, still got bug reports, though.  *sigh*)

> lanfear# make
> making sure the kern library is up to date...
> loading netbsd
> rearranging symbols
> strip: illegal option -- x
> usage: strip [-d] file ...
> *** Error code 1
> Stop.
> 	I'm hesitant to go and use this kernel after seeing something
> 	like that.

umm, that just means that it couldn't strip random symbols.
that kernel should be fine to use.
you'll need to remake/install strip to get it happy...  8-)

no kernel support is needed, though so a new kernel is unnecessary.

> 	Thus the question is---Is there something I can do to get 
> 	my machine up and running with the latest sources?  Can
> 	somebody recommend a sequnce of commands that might yield
> 	greater fortune.

well, make and install libgnumalloc, and install the latest
libs from /usr/src/lib, then the compiler/assembler/linker/assorted
utils, and take it from there.