Subject: Xcl and PicassoII
To: None <amiga-x@NetBSD.ORG>
From: Jose Alburquerque <>
List: amiga-x
Date: 12/15/1995 01:52:33
Hi.  I recently tried to install X.  Weird enough, the installation 
process seems to have gone all well.  Since I have a Picasso II, I 
decided to use Xcl as the X Window manager.  According to the README, it 
says that the files /usr/local/X11R6/lib/xdm/Xscript and 
/usr/local/X11R6/lib/xinit/Xserverrc should have the command:
   X -mono -dev /dev/grf3
to make sure it comes up.  I tried this to no avail.  I keep getting the 
error message: "mondef not ok" and it comes back with no change.  Just 
for curiousity, I tried using -dev /dev/grf0 instead and the entire 
process went uninterrupted, but I saw nothing on my screen.  I also 
noticed that moving my mouse and holding down the left mouse button at 
times, would cause some system response; I just couldn't see anything.  
Does anybody have any idea what's going on?  Is there some file I'm 
missing or do I need to reconfigure my system or something like that?

One final question:  My system is an A200 w/G-Force '030 25MHz.  I 
currently have a total of 9MB of 32bit memory on the board + 2MB Chip 
RAM.  The 9MB are divided into 2 segments of 5MB, and 4MB respectively.  
When I boot netbsd, It reports that it's using the 5MB.  I would just 
like it if it could use all the memory available so that X could run a 
little faster.  Here's a "dmesg":

NetBSD 1.1 (INSTALL) #0: Fri Nov 24 13:47:14 EST 1995
Amiga 500/2000 (m68030 CPU/MMU m68882 FPU)
real  mem = 5242880 (640 pages)
avail mem = 3735552 (456 pages)
using 44 buffers containing 360448 bytes of memory
memory segment 0 at 00200000 size 00400000
memory segment 1 at 01000000 size 00500000
memory segment 2 at 00000000 size 00200000
mainbus0 (root)
clock0 at mainbus0: system hz 100 hardware hz 715909
ser0 at mainbus0: input fifo 512 output fifo 32
par0 at mainbus0
kbd0 at mainbus0
grfcc0 at mainbus0
grf0 at grfcc0: width 640 height 400 colors 4
ite0 at grf0: rows 0 cols 0 repeat at (30/100)s next at (10/100)s has keyboard
fdc0 at mainbus0: dmabuf pa 0x1e3690
fd0 at fdc0: 3.5dd 80 cyl, 2 head, 11 sec [9 sec], 512 bytes/sec
zbus0 at mainbus0: mem 0x02b8c000-0x02bfbfff: i/o size 0x00200000
gvpbus0 at zbus0 rom 0xe90000 man/pro 2017/11: subprod b7 flags 40
gtsc0 at gvpbus0: dmamask 0x1ffffff flags 57 maxdma 65536
sc_clkfreg: 14.3Mhz
scsibus0 at gtsc0
gtsc0: target 0 now synchronous, period=208ns, offset=12.
gtsc0 targ 0 lun 0: <FUJITSU, M2684S-512, 2039> SCSI2 0/direct fixed
sd0 at scsibus0: 507MB, 2380 cyl, 6 head, 72 sec, 512 bytes/sec
gtsc0: target 6 now synchronous, period=208ns, offset=8.
gtsc0 targ 6 lun 0: <MAXTOR, 7120SCS, 3034> SCSI1 0/direct fixed
sd1 at scsibus0: 121MB, 1498 cyl, 4 head, 41 sec, 512 bytes/sec
grfcl0 at zbus0 rom 0x600000 man/pro 2167/11
grf3 at grfcl0: width 640 height 480 colors 16
ite3 at grf3: rows 60 cols 80 repeat at (30/100)s next at (10/100)s has keyboard
grfcl: 2MB Picasso II being used
grfcl1 at zbus0 rom 0xea0000 man/pro 2167/12
ite at grfcl1:  not configured
warning found rdb->secpercyl(166) != rdb->nsectors(42) * rdb->nheads(4)
warning lp->d_sparespercyl(2) not multiple of lp->d_ntracks(4)
2 mice configured
10 views configured

If *anyone* can help me I really will appreciate this!  I'm trying so 
hard to get X going, I'm almost desperate.  Thanks again :)