Subject: Re: Several minor problems
To: H}kan Th|rngren <>
From: None <>
List: amiga-x
Date: 02/27/1995 19:20:28
> I have a A3000, Retina-Z3 and NetBSD 1.0 with a slightly updated 1.0
> kernel that is very close to GENERIC.  (It has the recommended patch
> for Xamiga24 from and a patch for /dev/audio)

But it's essentially an 1.0 kernel or more like a current kernel?

> I compiled xanim without any problems, but when I try to run it, it opens
> a window, says something about using shared memory and then Xamiga24
> core dumps.  Has anyone else tried xanim?

I tried it... as long as it's not using shared memory, it works fine, no
sour aftertaste. But *IFF* I use shared mem (-B), xanim seems to work fine,
and some time after it exits, the whole system feezes, and on reboot, all
the superblocks of all at that time mounted filesystems are trashed! fsck
-b 32 fixes them fine, but I still thought that this is not really the way
things were thought to be... Note: I'm not really running a current "current",
could be that this problem has been fixed in the meantime.

> I have a strange problem with xfig.  It starts fine, but just before it gives
> control to me, it puts a filled rectangle (solid, with background color)
> in the middle of every button.
> It is about 75% of the button size which makes it very hard to use xfig.
> This problem also shows up if I start xfig on a SUN and use the Amiga as
> display.  I have not seen this on any other program.

Tried this, and have to confirm it.. hm.. looks like debugging session is
coming at me... grr :-)

> Is SUN3 compability broken?  When I tried a SUN3 binary, it complained 
> that it could not find, so I tried to copy from a SUN3.
> Now it says: map heap error (22) for /dev/zero
> File says 'mc68020 demand paged dynamically linked executable' on the SUN3.
> I had the impression that the only thing needed was some SUN3 shared
> libraries...

I'll certainly forget parts, here we go. Someone might put this into a FAQ...

1/ copy SunOS to /usr/lib/
2/ edit that with a binary editor (emacs will do), and do
   replace-string /usr/lib/ /sun/lib/
   replace-string /etc/ /sun/
3/ mkdir /sun
4/ ln -s {YOURSUNOSPARTITION}/usr/lib /sun/lib

that's it. Works for me. If you feel like it, chroot to the sunos-partition
and generate a file with "ldconfig", and copy that into /sun
as well.

> Is msdos floppy compability broken?  I can mount ados floppies, but it does 
> not want to mount PC-floppies (using mount_msdos).  I have tried both
> with HD and DD msdos-floppies, but no luck.  I have one of those half speed
> HD drives.

The floppy driver doesn't deal with ibm-encoded sector format (yet?). This
is not an issue of msdos-fs, it's deeper, in the floppy driver.

> It has UFS format and NetBSD complains that there is something wrong with 
> the super block.  I assume this means that there is some kind of incompability
> between UFS on NetBSD and SunOS 4.1.2.. :-(

Sounds pretty unlikely that they put ufs on a CD? Did they really??

EUnet Switzerland   Tel:     +41 1 291 45 80	Markus Wild
Zweierstrasse 35    Hotline: +41 1 291 45 60
CH-8004 Zuerich	    Fax:     +41 1 291 46 42	S=mw;P=EUnet;A=EUnet;C=CH
>Solaris 2 is not an upgrade from Solaris 1. They just want you to THINK it is.