Subject: Several minor problems
To: None <amiga-x@NetBSD.ORG>
From: H}kan Th|rngren <>
List: amiga-x
Date: 02/27/1995 10:50:45
I know that I have asked some of these questions before, but I have not
received any answers.  Possibly because some of my mail got lost
last week due to a local mailer problem.

I have a A3000, Retina-Z3 and NetBSD 1.0 with a slightly updated 1.0
kernel that is very close to GENERIC.  (It has the recommended patch
for Xamiga24 from and a patch for /dev/audio)

I compiled xanim without any problems, but when I try to run it, it opens
a window, says something about using shared memory and then Xamiga24
core dumps.  Has anyone else tried xanim?

I have a strange problem with xfig.  It starts fine, but just before it gives
control to me, it puts a filled rectangle (solid, with background color)
in the middle of every button.
It is about 75% of the button size which makes it very hard to use xfig.
This problem also shows up if I start xfig on a SUN and use the Amiga as
display.  I have not seen this on any other program.

Mosaic core dumps frequently.  When you get close to something like
FTP or gopher it just dies.  This is the Mosaic that is delivered in
the X11R6 extras (or whatever the archive is called).
I downloaded the source and tried to compile it, but it seems to require 
Motif.  Can I get Motif libraries somehow?  
I know it costs money, but I am desperate enough to pay at least some money 
for it.  

Is SUN3 compability broken?  When I tried a SUN3 binary, it complained 
that it could not find, so I tried to copy from a SUN3.
Now it says: map heap error (22) for /dev/zero
File says 'mc68020 demand paged dynamically linked executable' on the SUN3.
I had the impression that the only thing needed was some SUN3 shared

Is msdos floppy compability broken?  I can mount ados floppies, but it does 
not want to mount PC-floppies (using mount_msdos).  I have tried both
with HD and DD msdos-floppies, but no luck.  I have one of those half speed
HD drives.

The final problem I assume cannot be solved.  Our SUN CD-ROM player is broken
and SUN wants too much money to fix it.  
Well, lets try a CD-ROM player on NetBSD and export it via NFS to the
SUN, I thought.
I borrowed a Mac CD150 and after a lot of problems I found out how to mount 
CD-ROMs.  I could mount everything I tried except this Answerbook CD that 
holds all SUN documentation.  
It has UFS format and NetBSD complains that there is something wrong with 
the super block.  I assume this means that there is some kind of incompability
between UFS on NetBSD and SunOS 4.1.2.. :-(

        /H{\aa}kan  (mostly happy with NetBSD)

Use MS-Windows every morning and nothing worse will happen to you all day.