Subject: Re: xvt
To: None <>
From: Mike Heinz <>
List: amiga-x
Date: 02/02/1995 14:24:27

> ioctl(0, TIOCSCTTY, (char *)0);
> before you launch the shell.  This should go in the code after you've
> opened the slave pty and forked so that 0 applys to the shell's stdin.
> Ezra

	Thanks.  One of the programmers here at work pointed that out, and i 
tried it, but I immediately ran into another problem.  

I wrote a demo program that uses TIOCSCTTY and it worked fine, but when I 
added it to xvt, the slave process silently crashes - without even dumping core.
I tried to attach to it with gdb, but when I tried to examine the process, 
gdb crashed my X server!

	I'm almost certain the problem is >not< in ioctl itself, because I've
re-compiled xterm by hand and that works fine.  I just can't figure out why
the "grab the pty, fork, grab the tty" code works fine in my little demo proggie
but crashes inside xvt.

______________________________________________________________  _   _  ________
 Michael Heinz                                                 ((___))                                        [ x x ]
                                                                \   / 
 "A day job?!?  In an OFFICE!?!                                 (` ') 
  AAAAUUUUGGGGRRRRHHHH!!!"  - The Tick                           (U)