Subject: Retina Z3 hardware cursor problem
To: None <amiga-x@NetBSD.ORG>
From: Andreas Johansson <>
List: amiga-x
Date: 11/24/1994 01:08:17
Hello NetBSD:ers!

I apologize for this long letter. If you are not interrested in my problems,
please discard it.

I have been using the Xamiga24 Xserver for my machine a few days, and it works
pretty well except for the mouse pointer. It is positioned correctly in x-led,
but in y-led it will only use 5 different locations on my 1280x1024 screen.
That is, only the most significant 8 bits of the y cursor positioning actually
work as they should. I have tried to hardcode values in the RZ3SetHWCloc
function, but the mouse pointer will always be displayed at

Also, when the mouse is displayed at y=0 the image is shown in wrong colours.
Transparent and black colours are swapped. Some of the white lines are missing
and there is a white line just below the cursor. The xterm mouse pointer is
fine in this position, however. Very strange.

Some months ago I tried the first experimental X-server for the RetinaZ3 and
the same problem was there at that time.

Now, as I have tried to set values directly in the RZ3SetHWCloc, it seems that
the problem should be some setting up of those so-well-documented-registers.
The RZ3 hardware cursor naturally works as it should in AmigaOS.

Now for my configuration:

Amiga 4000/40 with 12Mb ram
GVP Impact series II SCSI controller with 512kB ram
	(currently in use since my Quantum 425 won't work with Scsi II)
A4091 SCSI II Fast controller
Quantum 425 prodrive connected to the GVP (this one is going to be sold!)
Micropolis 1Gb Fast SCSI-II drive connected to the A4091.
(No IDE disk)
Retina Z3 with 4Mb ram

I can't expect the above to have any effect as far as this problem is
concerned. Now for the odd part:

Hitachi CM2086 20" monitor, h-sync between 48-58kHz. I had to binpatch the
kernel with a hexeditor to get any display on this one :) Right now I am using
a 1280x1024@58kHz screenmode.

Now, as the monitor really shouldn't make any difference either, what's the
problem? I can't belive that any other NetBSD:ers with Retina Z3:s are
experiencing this - or the problem should have been solved long ago.

Oh, and I have compiled my own kernel with all my screenmodes and some other
small changes from the generic kernel.

If anyone could be able to help me with this I would be very appreciative.
I am getting rather annoyed with having to guess where the mouse pointer is
positioned. I have no idea what else to try except writing random data to
the registers or disassemble all the Amiga software for the RZ3, neither of
which are going to do me any good, I expect :)

Right now my Retina Z3 is broken (the vsync signal is dead) so if I won't be
able to test anything until I recieve a new one or the one I had is repaired.
However, I am still interrested if anyone knows what could be causing my

Now, on the topic of the RetinaZ3 kernel driver routines, I have looked at them
a little (actually I have ported the Retina Z3 console to Amiga Linux), and
it strikes me as a little unnecessary to busy wait for the blitter to finish.
Or are those 
	while ((blablabla & 1) == 0);
something else than I think? :)    Ok, what I would like to know is this:

Is the only reason for these busywaits and the not-so-clever-retina-memory-
management (that is, only framebuffer, pointer and temporary blitplace) that
noone has taken the time to enhance the routines? I surely would appreciate
if the machine would not have to swap portions of the display against
harddrive when there is >2.5Mb free in the Retina memory. Those 12Mb of mine
are not much when it comes to NetBSD-megs :)

On second thought, this is pretty odd. I belive PC-Linux is able to run X
without swapping with only 8Mb ram. My machine fills up all my 12 Mb as I
start X, xclock, xbiff, xload, four xterms and fvwm. Is linux really so much
more efficient (in ram usage) or is something wrong set up in my system?

Otherwise I must admit that NetBSD has worked very well and stable. I have had
some complete lock-ups though, often under heavy swap. I have not found any
pattern in theese freezes. The machine just stopped with the SCSI-led lit
sometimes and sometimes not. I remember reading something in the mailing list
about others that suffer from this, with small ram-configurations. The only
difference might be that I am filling my ram with X :)

Oh, anyway, the people that have brought NetBSD-Amiga to it's current state
deserve salutations!

: E-mail:                            Amiga 4000 is it! :
: S-mail: Andreas Johansson, Karhusvagen 5  6:618, 977 54 Lulea, SWEDEN :
:       There are two groups of people I'll _never_ understand:         :
:                     math-professors and women                         :